3

I've recently upgraded my laptop with XUbuntu to 19.10 and is very annoyed by new feature: when I tap at specific places on my touchpad (looks like it is right half of it) with tap-to-click enabled, it emulates middle mouse button instead of left one as I expect. This also happen on XUbuntu 19.10 live CD.

Where and how can this be disabled? I see no relevant switches in "Mouse and Touchpad" XFCE configuration. Of course, disabling tap-to-click stops middle clicks as well.

1
+50

I'm not fully sure if it will be what you expect, but you can disable all touchpad buttons except the left one by doing:

synclient RTCornerButton=1 RBCornerButton=1 LTCornerButton=1 LBCornerButton=1 TapButton1=1 TapButton2=0 TapButton3=0

If it is what you are looking for, you will have to edit the file /usr/share/X11/xorg.conf.d/70-synaptics.conf in order to make those changes persistent.

EDIT: To make persistent changes

To make changes persistent independently of any updates, you can either 1) create a script run at the startup such as suggested here: Execute a command 20 seconds after the desktop is booted.

In your case, it will be something like:

#!/bin/bash 

sleep 40
synclient RTCornerButton=1 RBCornerButton=1 LTCornerButton=1 LBCornerButton=1 TapButton1=1 TapButton2=0 TapButton3=0

Or 2) you can edit/create a xorg.cong file in /etc/X11/xorg.conf. However, I'm not advanced enough in Linux to recommend you to follow this solution because I'm not sure of the outcome. It's up to you.

Maybe someone else will be able to give you the right path to follow. From what I found online, it should look like that:

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "TapButton1" "1"
        Option "TapButton2" "0"
        Option "TapButton3" "0"
        Option "RBCornerButton" "1"
        Option "RTCornerButton" "1"
        Option "LTCornerButton" "1"
        Option "LBCornerButton" "1"
EndSection

Again, I can't certified it will works. It's your call if you want to try that.

You can read more about this here: https://manpages.ubuntu.com/manpages/cosmic/man5/xorg.conf.5.html and Where is the X.org config file? How do I configure X there?

  • The command seem to work for me. However, I'd recommend to avoid editing files in /usr as they can be replaced by update. It will be better if you'll give an example of /etc/X11/Xorg.conf that does the job. – val Nov 1 at 13:59
  • I have edited my answer to propose you how to make changes permanently. However, I can't be sure that the edition of the /etc/X11/xorg.conf will work because I'm not advanced enough for that. I'll rather prefer to create a script running at the startup. Safer for me. – dc37 Nov 1 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.