2

I updated to 18.04 and now my brightness keys are not working, even the brightness control bar isn't there. Sound control keys are working.

I checked for the graphics and there was this

llvmpipe (LLVM 8.0, 256 bits)

showing as graphics. I think this is why my brightness controls are turned off.

Any solution for this problem? Please answer for a newbie. I checked a few solutions but they were out of my understanding.

0

This usually happens when there is a missing driver.

First, run the following commands to enable the Universe and Multiverse repositories:

sudo add-apt-repository multiverse
sudo add-apt-repository universe
sudo apt update

The Multiverse repository contains "non-free" software that is free to use but is not considered free because of licensing and restrictions.

Next, run the following to install the the hardware enablement stack and the Intel HD graphics drivers:

sudo apt-get install --reinstall --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04 i965-va-driver-shaders libvdpau-va-gl1 libva2 libva-dev libva-drm2 libva-glx2 libva-wayland2 libva-x11-2

Reboot to apply the changes.

0

I was having exactly the same problem with a Dell Inspiron 5593, but in Ubuntu 16.04. I tried a lot of solutions on the Internet, but what finally solved my problem was updating the kernel version (https://phoenixnap.com/kb/how-to-update-kernel-ubuntu) with Ukuu.

If updating the Kernel version doesn't solve your problem, you can still come back to the last Kernel version (it's explained on the link)

If you are able to update the kernel, type the command

ls /sys/class/backlight/

And if your output has intel_backlight, then you are in the correct path to the solution, maybe you need to modify some parameters in the grub, but that would be all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.