I recently upgraded to 19.10 from 19.04.

Everything appeared to work correctly, however just last night I did a apt update/apt upgrade and some kernel updates occurred.

Now when I get to the login screen, I am unable to login. Upon entering the user password and hitting the login button, I am instantly sent back to the select user part of login.

Interestingly, if I use the GUI element to restart the computer, the warning shows that I am already logged in, even if I had not yet tried to log in after starting the computer.

Ctrl + Alt + F1-F6 freezes the screen and I am unable to do anything. Although Ctrl+Alt+Delete still works to restart the machine.

Selecting the latest kernel recovery boot from the grub menu works fine and I am immediately put into a desktop session (i3) after auto login. Once booted into recovery mode apt update/apt upgrade and dpkg --configure -a report 0 changes.

Any ideas on how to debug/fix this? I have a suspicion that my account is auto logging in, but then I am somehow bumped to the Ubuntu login screen where the strange state is causing issues.

I have a i5-4460 CPU, MS H81M-E34 (MS-7817) Motherboard, and a Geforce GTX 1050Ti graphics card. I am using the nvidia-driver-430 package.

  • Welcome to Ask Ubuntu! I recommend you edit this to give the make/model of your machine (or what motherboard it has, if custom-built) and what graphics card it has. If you can also include the output of sudo lshw -C display, that may help. From that comment it sounds like you may be saying you have an Nvidia card, but I am not sure if that's the case or which one. Also, if workarounds have helped--like booting an earlier kernel--you can give details about that too. Oct 23, 2019 at 23:10

3 Answers 3


Same here. I've ended up removing the Nvidia driver:

sudo apt remove nvidia-*

It's not a full fix but at least I can log in again and get to a desktop.

  • 1
    Thats good info. I can rollback the kernel until the driver is fixed. At least I know what is broken now! Oct 23, 2019 at 20:22

Bug report: https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/1845801

Valtteri Vainikka (vrln) wrote on 2019-11-08:

I think Martin on to something concerning GRUB/Linux boot options, more specifically the "splash" one. With testing-updates enabled what currently happens for me:

If I set automatic login on I'm stuck with the standard infinite login loop, but with the distinction that I can now no longer enter another TTY via ctrl+alt+F3 for example to fix it straight away. The whole system now just freezes, so I fixed it via recovery mode.

Out of curiosity I then went and disabled the following line in /etc/default/grub and ran sudo update-grub:


Result: Automatic login now works perfectly, no issues anymore.

Another more radical approach is to disable auto-login.

NOTE: This grub config line keeps reappearing after some system updates that include a grub update, and you have to start again this process.

  • it is also possible to enable a login timeout for example of like 3 seconds. just open the file /etc/gdm3/custom.conf in your tty session and comment out the automatic login and comment in the timed login, also set the correct username. but still just a workaround
    – d3rdon
    Nov 19, 2019 at 8:37
  • 2
    This worked for me. However, today's Ubuntu software update broke even this workaround. So now I have to revert to disabling automatic login...
    – mikeglaz
    Nov 25, 2019 at 18:48
  • Also worked for me however I have a feeling the next update will break this
    – Exile
    Jan 4, 2020 at 20:04

I have the exact same issue on my desktop. I fixed it like this:

  1. Uninstall the nvidia driver.

    I uninstalled cuda with 418 driver from cuda10 directory with uninstall script. and also from cuda10.1 directory. Then I used the script sudo apt remove nvidia-* to clean things up.

  2. Disable automatic login (even if you never enabled it, it is set to automatic in 19.10 for some reason). You can find this in System Settings → Detail → Users.

  3. Install the nvidia-435 driver from Additional Drivers.

  4. Reboot.

  • The nvidia driver page (nvidia.com/Download/index.aspx) indicates I should use the 430 driver package, and also shows the 435 package as being older. Do you know what the difference between the two packages is? Oct 24, 2019 at 3:30
  • @SamCoulter no idea, I was on 430, I thought 435 is newer so I installed that...
    – Zark Fury
    Oct 24, 2019 at 12:12
  • @TensorVortex Your solution (disabling auto login) worked for me! I had this issue ever since upgrading to 19.10 and had to rollback to nouveau on my old GTX750. Ive since upgraded to 1660 and was forced to use nvidia drivers. I had the same freeze issue with nvidia-440 installed but disabling auto login worked! Also for anyone having trouble, booting into recovery mode will allow you to access your linux to make changes
    – Kevin Pei
    Oct 29, 2019 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.