While upgrading my system from 19.04 to 19.10, there was power failure. Due to partial upgrade,my system after login shows me black screen for a while and then shows white screen with text on it- "Oh no! Something has gone wrong. A problem has occured and the system can't recover. Please logout and try again."

Error after login image

I tried every possible thing available on Ask Ubuntu and Stack Overflow like upgrade, update, reconfigure lightdm etc. Nothing seems to work for me. Can someone help me with this ASAP?

I don't have backup of my data. So it would be great if you help me get my data back.

Thanks in advance:)

  • 1
    Have you tried CRTL+ALT+F1, login in textmode and remove rm ~./Xauthority, yet? – Fiximan Oct 23 '19 at 11:58
  • Personally I wouldn't do what @Fiximan suggested, however I would firstly boot a 'live' media & fsck (file system check) your file-system. Then I would boot your system & login to terminal (not touch your gui) and try and continue upgrade; ie. sudo apt full-upgrade. I would also sudo apt update (look over what I see; is it eoan sources & no disco without errors), then sudo apt full-upgrade again (should be no upgrades this time). Then reboot, and try and login normally (ie. now try GUI). Since you didn't backup, I'd also probably make a copy of data after fsck before booting... – guiverc Oct 23 '19 at 12:24
  • Personally if I saw something on youtube, I'd not trust it, until I knew who the source was. Myself I tend to stick to site:*.ubuntu.com (ie. official Ubuntu) and even then I look bottom right to see when it was last edited (for a clue; something things change heaps so date is significant; other things rarely change so years old could still be perfectly accurate). Low graphics is a warning & relates to GUI (as stated, I'd only use text mode until system was stable/fully-upgraded). I also wouldn't install/remove/touch anything till fsck was done (using 'live' media) as already outlined. – guiverc Oct 23 '19 at 13:07
  • @fiximan I did try. Didn't work for me. I even created another account. When logged in from the new account, got the same error. – Harshitha H Prabhu Oct 26 '19 at 18:34

I had the exact same issue and fixed it by following below steps:

Trigger CLI from the error screen using Ctrl+Alt+F3 and Login. Then execute the command for release upgrade:

sudo do-release-upgrade

If there was issue with new release download, this should solve it, else it will print out:

No new release found.

If so, continue by updating the package lists and upgrading it.

apt-get update && apt-get upgrade

If there was a issue here, the system will ask you to execute the command suggested by Schwab Eugen.

sudo dpkg --configure -a

The system will finish unpacking and installing the missing resources. After that just reboot the machine and it should will work.

  • Thanks. I tried it. Didn't work. There's something serious that's happened in my system. – Harshitha H Prabhu Oct 29 '19 at 8:54
  • it worked for me. Thank you very much, because i started to worry a little bit. – kailor Dec 7 '19 at 1:03

To me it sounds during the upgrade when power was lost, important files critical to system function were corrupted due to being incompletely written. I'll provide some advice that I think might work. I don't know everything about Ubuntu so I apologize if some methods are impossible.


This method assumes you have 2 machines networked together that both support SSH and have SSH enabled.

First, you can try by accessing a TTY shell (Ctrl+Alt+FunctionKey), if it works you should appear in a text-only interface that prompts you to login. From there, you can input your username and then password, don't panic if you don't see the password being displayed on screen. If you can get in, you can use a TTY session to copy files you need via the scp command. If you can't login and you have typed everything correctly, then there might be something wrong with PAM (Pluggable Authentication Module, used to verify passwords for instance) or another service.

Live Session

This method assumes you have 2 computers and a USB drive.

If you have another computer to work with and you have a spare USB drive, you can burn an Ubuntu image onto it via a program like balenaEtcher. After doing so, plug it into your machine and start it up.

(NOTE: If you use an Nvidia GPU you might want to enter the GRUB config, enter the editing mode and attach nomodeset onto the end of your /boot/ line then boot, otherwise there's a chance the machine will lock up during this process. It will look bad but it will work)

After doing so, you can enter a live session (do not choose to install), then you can open a terminal and run lsblk to list all drives. After finding the drive with the data on it, you can mount it using the mount command. You then can navigate onto the drive from Ubuntu's file manager, and upload files to a service like Google Drive or a NAS (Network-Attached Storage) device.


I had the same problem with a boot loop after release upgrade. I've used:



sudo dpkg --configure -a

Alt+F2 to return at Login Page as usual.


The same happened to me, and the only way to fix it was to use a live usb session to recover my data (I transferred it to another partition) and making a fresh install of Ubuntu 19.10. However, after that, I had another login related problem, but related to my NVIDIA Graphic Card, which was that.

Not the answer you're looking for? Browse other questions tagged or ask your own question.