10

I have downloaded Virtualbox from the official repository. However, I can't manage to install it on Ubuntu 19.10:

> lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 19.10
Release:    19.10
Codename:   eoan

It says that my configuration does not have some dependencies:

dpkg -i virtualbox-6.0_6.0.14-133895~Ubuntu~bionic_amd64.deb 
Selecting previously unselected package virtualbox-6.0.
(Reading database ... 183239 files and directories currently installed.)
Preparing to unpack virtualbox-6.0_6.0.14-133895~Ubuntu~bionic_amd64.deb ...
Unpacking virtualbox-6.0 (6.0.14-133895~Ubuntu~bionic) ...
dpkg: dependency problems prevent configuration of virtualbox-6.0:
 virtualbox-6.0 depends on libqt5opengl5 (>= 5.0.2); however:
  Package libqt5opengl5 is not installed.
 virtualbox-6.0 depends on libqt5printsupport5 (>= 5.0.2); however:
  Package libqt5printsupport5 is not installed.
 virtualbox-6.0 depends on libqt5x11extras5 (>= 5.6.0); however:
  Package libqt5x11extras5 is not installed.
 virtualbox-6.0 depends on libsdl1.2debian (>= 1.2.11); however:
  Package libsdl1.2debian is not installed.
 virtualbox-6.0 depends on libvpx5 (>= 1.6.0); however:
  Package libvpx5 is not installed.

dpkg: error processing package virtualbox-6.0 (--install):
 dependency problems - leaving unconfigured
Processing triggers for systemd (242-7ubuntu3) ...
Processing triggers for gnome-menus (3.32.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu1) ...
Processing triggers for mime-support (3.63ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for shared-mime-info (1.10-1) ...
Errors were encountered while processing:
 virtualbox-6.0

Running sudo apt-get install -f won't install the dependencies, but will remove the uncomplete installation of Virtualbox. Am I missing something?

7
  • You mention from the official repositories, on 19.10 that's packages.ubuntu.com/eoan/virtualbox but your package is listed as being a Bionic (18.04) package; ie. it's unofficial for eoan. Use the official 'eoan' package
    – guiverc
    Oct 23 '19 at 7:00
  • 1
    A sudo apt install virtualbox will work; your issue is trying to install an unofficial (official for 18.04 but you're not running 18.04 thus it's unofficial) package.
    – guiverc
    Oct 23 '19 at 7:03
  • I downloaded it yesterday directly from the website...I'm running 19.10 oracle.com/virtualization/virtualbox
    – Firefox264
    Oct 24 '19 at 12:47
  • 1
    I upgraded to 19.10 yesterday, and now Virtualbox won't start my VM, saying Kernel driver not installed (rc=-1908) and suggests running '/sbin/vboxconfig' as root. This also fails, compiling kernel modules ends with this log entry: /tmp/vbox.0/r0drv/linux/mp-r0drv-linux.c:287:18: error: void value not ignored as it ought to be 287 | int rc = smp_call_function(rtmpLinuxAllWrapper, &Args, 0 /* wait */); What to do?
    – Enno
    Oct 25 '19 at 6:41
  • If you look on the downloads page you posted the link to. There isn't a download option for Ubuntu 19.10 so I take it from that that VirtualBox 6.0.14 for Linux doesn't yet support 19.10 the only download links are listed on that page are: Ubuntu 18.04 / 18.10 / 19.04 ?
    – user993560
    Nov 29 '19 at 21:51
13

To install the official package and testing VirtualBox for your release, you need only

sudo apt install virtualbox

That will cause https://packages.ubuntu.com/eoan/virtualbox to be installed (note: it's found in 'multiverse' so that repository must be enabled; https://help.ubuntu.com/community/Repositories/Ubuntu)

You are trying to install a virtualbox packaged for bionic (18.04) which is unofficial for Ubuntu 19.10 (eoan). It needs to be removed (if installed) and the official 6.0.14 package installed from official repositories (for eoan).

6
  • 2
    I'm using virtualbox on my 19.10 system, and using the default version; apt-cache policy shows 6.0.14-dfsg-1 from eoan/multiverse ; and use it regularly without issue (I've done 30+ 19.10 QA-tests using it over last couple of months)
    – guiverc
    Oct 23 '19 at 7:26
  • Yes that is the same version (6.0.14) available for download from Oracle and the apt version maybe even has some extra bug fixes. I agree, there is no need to use the downloaded file when apt provides the same version.
    – mchid
    Oct 23 '19 at 7:31
  • This doesn't work for me. It seems to install fine, but in reality the kernel modules don't load. sudo modprobe vboxdrv gives "modprobe: ERROR: could not insert 'vboxdrv': Exec format error". I have the 4.15.0-1059-oem kernel on Kubuntu (if that matters)
    – larsivi
    Nov 19 '19 at 18:43
  • The version from apt is typically crippled, that's why one has to go to virtualbox.org to download it and the "extension pack." Has that finally changed? Dec 6 '19 at 21:10
  • I only ever use the standard Ubuntu packages and don't have problems. Maybe it helps that I'm usually running the latest release (and/or development) thus get no benefit going outside Ubuntu packages (only aware of complications with non-Ubuntu sourced packages when I next release-upgrade which is every six months).
    – guiverc
    Dec 6 '19 at 22:09
2
nano /etc/apt/sources.list

write inside:

deb http://cz.archive.ubuntu.com/ubuntu disco main 

save with these shortcuts: Ctrl+O and Ctrl+X

next:

apt-get update
apt-get install libvpx5
1
  • 1
    It is a pretty bad idea to mix distro versions like this. Never do this. Next system upgrade is bound to bring some terrible surprises.
    – Marek Rost
    Jul 18 '20 at 8:59
2

As guiverc mention, you can do it in more simple way, just sudo apt install virtualbox

But for example, in my case, I had a vagrant, which specifically ask for `virtualbox-5.2'

Same you can do it like this: sudo apt install virtualbox-5.2, but for some cases it did not helped me. So I tried Josue Badbeat solution and it helped. Just add in source.list -> deb http://cz.archive.ubuntu.com/ubuntu disco main and then

apt-get update
apt-get install libvpx5
0

I had the same question. I tried installing libvpx5 but that didn't work.

sudo apt install virtualbox 

worked just fine

0

If none above solved your problem, do this

There is a bug with gcc (reference)

sudo ln -fs gcc-8 /usr/bin/gcc

then download the latest version of the virtual box from this link or use type:

wget -q https://download.virtualbox.org/virtualbox/6.1.0/virtualbox-6.1_6.1.0-135406~Ubuntu~eoan_amd64.deb

then, in the command shell, go to the directory where you downlaoded the vritualbox, and run:

sudo dpkg --install virtualbox-6.1_6.1.0-135406_Ubuntu_eoan_amd64.deb

-1

I just installed Virtualbox-6.1 using the Bionic App repository. I did have to install libvpx5 using

dpkg -i from https://ubuntu.pkgs.org/19.04/ubuntu-main-amd64/libvpx5_1.7.0-3_amd64.deb.html

but it seems to work fine. Hopefully Oracle will add Eoan soon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.