I have a Dell 9570 XPS laptop with latest BIOS (1.13.0) and I am trying to do a clean install of Ubuntu 19.10 from a flash drive. It is failing from two flash drives, one USB and one USB-C, with these steps.

  1. Reboot with flash drive inserted.
  2. Hit F12 and select flash drive as boot option (under UEFI).
  3. Grub screen loads, select any install / try option (with or without safe graphics)

Fails with:

error: cannot allocate kernel buffer.
error: you need to load the kernel first.

press any key to continue...

Pressing any key takes me back to the grub selection screen. I am able to load a grub command line.

I have tried all combinations of secure boot, fast boot, legacy rom mode / legacy BIOS boot I can think of. Nothing has an impact except booting the flash drive via LEGACY EXTERNAL DEVICE BOOT, which loads the grub selection screen with nice graphics, and will successfully complete the installer.

However, I cannot then boot from the hard drive and even if I could, I want to use UEFI and secure boot.

Googling "cannot allocate kernel buffer" finds nothing that seems relevant.


I also tried installing off a 19.04 USB stick, which does work. I installed 19.04, then upgraded to 19.10. However, 19.10 then fails to boot with the same error.

I also tried creating the usb install from windows with Rufus, rather than with Startup Disk Creator from Ubuntu. Same issue.

It also seems to be now flashing briefly error: file /boot/ not found, before it hits the grub installer option screen.. Actually, this seems to only occur when booting from USB-C flash drive, not from USB.

I also.. tried from a Dell XPS 7590 with BIOS 1.2.3 and the USB stick boots fine. This be specific to my hardware / BIOS config / BIOS version somehow. I guess I will wait until either a new 19.10 release comes out, or my BIOS gets a new version.

Update: 1.14.0 BIOS version made no difference.

  • Did you get a fix for this yet? I've hit the same thing. I've done some reading and the general consensus is to disable secure boot. I've done that and am still hitting the same issue as you describe. I have the latest bios, tried different keys and different settings in the bios, but issue remains... Oct 28, 2019 at 5:46
  • @SteveCarter Nope, I'm totally stuck. My plan is to wait for either a new BIOS version, or an update to the 19.10 ISO and try again.
    – AlistairB
    Nov 6, 2019 at 21:39

1 Answer 1


EDIT: I have removed my original feedback and updated with the following after doing some testing. This is not a Ubuntu issue. It is a an installation medium issue. I'd say its a "gotcha" that you need to pay close attention to. I don't know why I'm seeing it now and not before - maybe just lucky, but I can say that the following resolved the issue for me... After experiencing the same issue, I now have installed Ubuntu 19.10 in UEFI mode.

I had success by creating the bootable media in windows using Rufus https://rufus.ie/
Notable changes to the defaults. Partition scheme must be GPT. Target system had to be set to UEFI (Non CSM) It should be noted that the above 2 changes appear to be requirements of a UEFI bootable system. More info from https://wiki.restarters.net/UEFI_and_GPT

I'm quite certain you cannot boot UEFI without a GPT partition table. Perhaps someone more experienced in this field may confirm this...

When I did the install originally on both a recovery linux boot disk and Ubuntu 19.10, i was met with the exact same error. I changed the settings as per below and the issue went away immediately.

I now have a working install of 19.10 Ubuntu.

enter image description here

  • 1
    Thanks, but I think my issue is different. Every version of ubuntu has worked with UEFI and secure boot, except 19.10. I can complete the install for 19.04 from USB on UEFI, then upgrade to 19.10 then can't boot.
    – AlistairB
    Oct 28, 2019 at 22:42
  • 1
    Unfortunately, Partition scheme GPT didn't make any difference.
    – AlistairB
    Oct 30, 2019 at 7:52
  • 1
    hmm, the same issue on 2 different flavours of Linux were resolved by the above. That and disabling secure boot. If it's not that, then I still don't think its anything to do with Ubuntu itself. I'd be looking at something in your bios. Best of luck with it, sorry I couldn't help further... Oct 30, 2019 at 8:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.