9

Had my dock on bottom (+autohide) in Ubuntu 19.04. After upgrade to Ubuntu 19.10 it disappeared and can be found now only in Activities overview.

I can start apps from there and it has all apps that I have added there but can't get it to be in the original place and on desktop, not in Activities.

Tried Settings -> Dock and none of the 3 settings (Auto hide, Icon size, Position) have any effect.

Output $apt policy gnome-shell-extension-ubuntu-dock

gnome-shell-extension-ubuntu-dock:

Installed: 67ubuntu19.10.1

Candidate: 67ubuntu19.10.1

Version table:

*** 67ubuntu19.10.1 500

500 http://archive.ubuntu.com/ubuntu eoan/main amd64 Packages

500 http://archive.ubuntu.com/ubuntu eoan/main i386 Packages

100 /var/lib/dpkg/status

Restarting desktop with "r" does not correct the proble, Dock still in Activities.

1
  • 1
    According to a comment by user paravane on gnome extensions site, "To everyone getting errors after upgrading to 19.10 ALT+F2 type "r" then press enter. (without the quotes) This will restart your shell and your dock will appear at the bottom." Oct 23, 2019 at 15:04

6 Answers 6

15

I had the same problem. I uninstalled dash to dock extension and execute this

dconf reset -f /org/gnome/shell/extensions/dash-to-dock/ 

then reboot.

1
  • just a reminder, reboot !
    – Digao
    Nov 19, 2020 at 11:30
5

I had the same problem and this worked for me I reinstalled 'ubuntu-dock' by using this command:

sudo apt install gnome-shell-extension-ubuntu-dock

check for docks in settings after the installation

If it's already installed, but problem persists try to reconfigure it with:

sudo dpkg-reconfigure gnome-shell-extension-ubuntu-dock
2
  • 2
    This is not dash-to-dock, this is ubuntu-dock.
    – Alexey
    Jun 13, 2020 at 17:21
  • I had the same problem, even Dock section in settings wasn't working until I installed this package
    – JLarky
    May 12, 2021 at 21:07
1

I had the same problem and this worked for me I reinstalled 'dash to dock' by using this command:

sudo apt install gnome-shell-extension-ubuntu-dock

The workaround is to reboot the Gnome shell by following the protocols presented below. 1.Press ALT + F2. 2.In the pop-up terminal, type r and press Enter.

The Gnome shell will restart without breaking the existing processes.

0

Try activating Ubuntu dock under the Extensions tab of the GNOME tweak tools.

0
sudo apt install gnome-shell-extension-ubuntu-dock
sudo mv ~/.local/share/gnome-shell/extensions/ubuntu-dock@ubuntu.com /usr/share/gnome-shell/extensions/
  • Then Press F2 and type r

References

0

Similar to this, immediately after upgrading from 21.10 to 22.04 Jammy, I had no Dock. Also under Appearance in the Settings application there was only a section for Style, no section for Dock. After a couple of restarts and still no Dock, I ran

sudo apt install gnome-shell-extension-ubuntu-dock

(as mentioned above in a previous answer) and restarted. The Dock is back and a Dock section now appears under Appearance in Settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.