10

It's Kubuntu to be more precise. BTW my network works and i have tried to remove the 32bit architecture/packages.

sudo do-release-upgrade
Checking for a new Ubuntu release
Get:1 Upgrade tool signature [1,554 B]                                                                                
Get:2 Upgrade tool [1,319 kB]                                                                                         
Fetched 1,320 kB in 0s (0 B/s)                                                                                        
authenticate 'eoan.tar.gz' against 'eoan.tar.gz.gpg' 
Authentication failed
Authenticating the upgrade failed. There may be a problem with the network or with the server.

EDIT: So what i did was to open sources.list and substitute "disco" with "eoan". It everything works so far after the upgrade.

3
  • 1
    I don't know what mirror you are using, but I'd suggest checking your chosen/used mirror is up-to-date (or only a few hours behind); launchpad.net/ubuntu/+archivemirrors for if it's last update unknown especially (counter on it's last update has overflowed!), that could be your problem, ie. use a maintained mirror. – guiverc Oct 23 '19 at 5:25
  • Gonna try another mirror; right now seems like changelogs.ubuntu.com/meta-release is offline tho'. – Azarilh Oct 23 '19 at 20:49
  • Nope, i still get the same error. – Azarilh Oct 24 '19 at 0:15
9

bentolor's answer led me to a different command which seemed to ultimately fix the problem:

sudo apt-get install --reinstall ubuntu-keyring

I'm guessing this restores the keyring to defaults, something must have changed since the package was last installed. Now I can run the command sudo do-release-upgrade -m desktop without the Authentication failed error.

3
  • 2
    Good, these replies are better then everything i found around the Internet. Next time ima gonna try this. – Azarilh Nov 1 '19 at 2:23
  • 1
    This worked for Ubuntu 18.04 to 19.04 upgrade as well. – Ashok Jan 10 '20 at 18:49
  • 1
    I got a brand new Dell Precision with Ubuntu 18.04 and it has the error described here. OUT OF THE BOX! This fix worked. – pauljohn32 Apr 28 '20 at 1:56
4

I ran into the exact same problem. The problem is a missing signing gpg key 871920D1991BC93C. apt-key adv --keyserver http://keyserver.ubuntu.com:80 --recv-keys 871920D1991BC93C did not solve the issue as the key doesn't seem to publicy available.

But

$ sudo apt-key update
Warning: 'apt-key update' is deprecated and should not be used anymore!
gpg: key 3B4FE6ACC0B21F32: 3 signatures not checked due to missing keys
gpg: key 3B4FE6ACC0B21F32: public key "Ubuntu Archive Automatic Signing Key (2012) <ftpmaster@ubuntu.com>" imported
gpg: key D94AA3F0EFE21092: 3 signatures not checked due to missing keys
gpg: key D94AA3F0EFE21092: public key "Ubuntu CD Image Automatic Signing Key (2012) <cdimage@ubuntu.com>" imported
gpg: key 871920D1991BC93C: 1 signature not checked due to a missing key
gpg: key 871920D1991BC93C: "Ubuntu Archive Automatic Signing Key (2018) <ftpmaster@ubuntu.com>" not changed
gpg: Total number processed: 3
gpg:               imported: 2
gpg:              unchanged: 1

helped. After that I was able to start the upgrade. This was a very long-term installation continuously updated.

0

Contrary to what Bentolor said in his answer, this command solved the problem for me:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 871920D1991BC93C

Here is the reasoning behind the solution: https://askubuntu.com/a/1281413/63606

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.