I'm running Kubuntu 18.04 on an HP Pavilion with Ubuntu Studio installed, connected via USB to a Yamaha electric piano. When I start either Rosegarden or aplaymidi on a MIDI file, the sound emerges from the piano for about 15 seconds and then cuts out. (The program continues running and still displays progress.) Only a restart will revive the sound. It doesn't matter whether I try Rosegaden or aplaymidi after the cutout. I'm pretty sure neither the piano nor its settings are at fault since everything works correctly in Windows 10 with Yamaha's USB driver (this a dual-boot machine), even when I switch back and forth between Windows and Kubuntu.

How can I track this down?

Update: I tried modifying /etc/default/grub as suggested in the reply:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="usbcore.autosuspend=-1 quiet splash"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


I then did:

sudo update-grub
sudo grub-install /dev/sda

The behavior did not change -- the sound still quit after about a minute.



You must log in to answer this question.

Browse other questions tagged .