I've been stuck for 2 days on this. I can't boot into Ubuntu after a fresh 19.10 install on my Acer Aspire E15 E5-576 laptop . after I reboot there is no grub menu and it goes straight to Windows 10. What I've tried:

  1. The steps reported here How can I repair grub? (How to get Ubuntu back after installing Windows?). Got no errors but it still doesn't show grub on startup.

  2. Booted the live boot repair disk, performed the boot repair. Nothing changed.

  3. Went into bios to change boot order but there is no grub option, only windows boot.

  4. From windows cmd with admin rights entered

    bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

    This worked. I can now see the grub menu and successfully boot into the Ubuntu partition. However I cannot access Windows 10 anymore. There is a Windows boot option in grub but if I select it, it loops into the grub menu forever.

    To go back into Windows I had to manually recreate the efi partition from the live Windows 10 disk, and after that, it boots straight to Windows 10 again.

I don't know what else to do. I'm in your hands. Thank you for your help


4 Answers 4


19.10 comes with a new version of Grub 2.04 that many have reported bugs with.

A common solution is to turn off TPM in BIOS. However other options are detailed in the bug reports and there other things to try if that doesn't work.


I have a recent model desktop ASUS motherboard, and upgrading the BIOS helped with the grub issues of 19.10


windows loader is a bit finicky. i did the following, i don't know if this is the state-of-the-art way, but at least it worked.

if you had your boot files copied to the windows efi partition like i did, you can start windows, else you first have to use a live stick to copy your boot files to the windows efi partition. make sure you have grubx64.efi, shimx64.efi, mmx64.efi, grub.cfg and BOOTX64.CSV, in the directory


in windows you can mount the efi partition and copy the files with:

mountvol x: /s

then you have to change the default bootloader for windows to grub. for me it didn't work if the linux bootfiles were in any other directory than the one i mentioned.

bcdedit /set {bootmgr} path /EFI/Microsoft/Boot/shimx64.efi

shim is the shoehorn which puts grub into a system with secure boot enabled.

after a restart it should hopefully work.


@oldfred has the best answer for OP Acer related issues. Typically for Acers, hold down the F2 key after booting to get to the boot settings [UEFI]. Then highlight 'security' menu, then down to highlight the option to trust a UEFI file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.