9

I can see this in lsusbenter image description here but cannot find option to use it in users option in setting

8
  • 1
    See dell.com/community/Linux-General/… which was the first answer found by a web search on Goodix FingerPrint 27c6:538d Linux
    – K7AAY
    Oct 21, 2019 at 20:02
  • 1
    @K7AAY that thread talks about device 27c6:5301 . But in my case device is different and also lsusb is able to show that name of device. Oct 23, 2019 at 10:11
  • 1
    I'm in the same boat here with an Inspiron 5493. lsusb shows the device as a Goodix fingerprint scanner. However, lshw | grep -a10 -i goodix notes that this device is "UNCLAIMED". Could this mean that there is no driver for the fingerprint scanner even though it's identified and shown in lsusb?
    – kamses
    Oct 25, 2019 at 16:10
  • @VikasKumar: Did you ever find a solution for this?
    – user000001
    Dec 1, 2019 at 19:25
  • Possible duplicate of askubuntu.com/questions/872175/…
    – Elder Geek
    Dec 1, 2019 at 21:51

1 Answer 1

6

It seems these Dell laptops are certified and they have similar Goodix fingerpint readers: https://certification.ubuntu.com/catalog/component/27c6:538c It's worth trying the 4.15 oem kernel. It didn't work for me on a 5.4 oem kernel.

I read on the Goodix forum they do not plan to open source drivers but are working with Dell to provide drivers. Let's hope it will be open sourced.

It's best to get involved in the fprint development website. Here is the issue for your hardware:

https://gitlab.freedesktop.org/libfprint/libfprint/-/issues/196

hope that helps.

[UPDATE] It works for my device with the new proprietary drivers from Goodix.

You can do the following:

sudo sh -c 'cat > /etc/apt/sources.list.d/focal-dell.list << EOF
deb http://dell.archive.canonical.com/updates/ focal-dell public
# deb-src http://dell.archive.canonical.com/updates/ focal-dell public

deb http://dell.archive.canonical.com/updates/ focal-oem public
# deb-src http://dell.archive.canonical.com/updates/ focal-oem public

deb http://dell.archive.canonical.com/updates/ focal-somerville public
# deb-src http://dell.archive.canonical.com/updates/ focal-somerville public

deb http://dell.archive.canonical.com/updates/ focal-somerville-melisa public
# deb-src http://dell.archive.canonical.com/updates focal-somerville-melisa public
EOF'
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys F9FDA6BED73CDC22
sudo apt update -qq

sudo apt install oem-somerville-melisa-meta libfprint-2-tod1-goodix oem-somerville-meta tlp-config -y

I needed a reboot to have the fingerprint scanner working:

Bus 001 Device 002: ID 27c6:538c Shenzhen Goodix Technology Co.,Ltd. Fingerprint Reader

You may need to run :

sudo pam-auth-update

to enable fingerprint for logging in (make sure there is a star). Work continues on open source drivers too, hopefully these drivers help for reverse engineering.

Anyone knows how to unlock the keyring too? That doesn't seem to happen currently when logging in with fingerprint...

4
  • Glad that it worked for you, but your hardware is different from the one in the question. In this answer you have 27c6:538c, whereas the questioner (and myself) have 27c6:538d (Note the final letter). Do you have any idea if anything similar is possible for the fingerprint module in the question?
    – user000001
    Aug 28, 2020 at 16:23
  • hi, did you try it? It's likely that a driver supports multiple id's. You can try and look in the package for your id, or even try to change or add it in the driver, but why not just try it? Aug 29, 2020 at 15:35
  • 1
    yes I tried it, but it's not detected, when I run fprind-enroll I get no device found
    – user000001
    Aug 29, 2020 at 15:38
  • I grepped the source, your ID is not in there. You could try to recompile with your id and see what happens : git clone git://git.launchpad.net/~oem-solutions-engineers/libfprint-2-tod1-goodix/+git/libfprint-2-tod1-goodix. Otherwise, file a bug (like this one bugs.launchpad.net/usbutils/+bug/1721909 ) and use this website/ticket : gitlab.freedesktop.org/libfprint/libfprint/-/issues/196 to track it. The main issue is that the vendor does not supply info to develop, but people try. You can see what role you can play that best fits your competence. Any help is appreciated! Aug 29, 2020 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.