2

This seems to be very badly documented, and while there are many questions similar to this one, none really deals with this exactly, nor seems there to be a solution.

I am on Ubuntu 18.04 LTS using the xfce4 desktop and I normally use UK English, my physical keyboard is UK English.

However I need to write other languages now and then, for this reason, I use UK English (dead keys) for languages with accents and umlauts.

I was also able to get Farsi (Persian) to work: just choose Keyboard Preferences - Layouts, hit the +Add button and add Persian. When I enable that language the Farsi characters will show up when I type.

In order to see which character appears for which key on my (UK) keyboard I can look at the layout using the "Show Current Layout" function. When I show the "onboard" virtual keyboard, it automatically switches between the UK, UK dead keys and Farsi characters which makes it easier to enter the correct characters.

HOWEVER: when I try to do the same for Korean, nothing works at all. There is a "Korean" option in the same list from which I selected Persian, but choosing it does not change anything and the layout shows latin characters instead of Hangul (Korean characters).

After consulting many pages on the web I got fcitx to run but while the fcitx menu has an option to choose a virtual keyboard and show it, Korean never shows up in the list, even if the Korean input method is selected. I found no way to figure out what the layout of the korean keyboard is and how to enable a Korean virtual keyboard. Enabling Korean/Hangul also works only rarely, the language often changes to English by itself or just by moving the mouse.

When I activate the Korean input method and I get it to work in a window, as soon as the virtual keyboard display is toggled, Korean is deactivated and I am back to Latin (which is also shown in the virtual keyboard). Also while I can type in a terminal, I cannot get it to work in Google Chrome at all.

Am I missing something or is it simply not possible to enter Korean/Hangul using a virtual keyboard using Ubuntu as of 18.04?

2
  • Did you get it to work in the end?
    – mikerover
    Aug 28, 2020 at 22:22
  • No, sadly not, I gave up.
    – jpp1
    Aug 29, 2020 at 7:34

1 Answer 1

3

I just managed to get it! (I've actually yelled "eureka"!) This is for Linux Mind Ullya and I am about to do the same for my Ubuntu 20.04 LTS.

This is how I did:

First Part - Install IBus:

Step 1: Install and set up IBus Open the terminal and run the below command

sudo apt install ibus-m17n

Step 2: Get the language right On the terminal run the command below hor the Hangul option

sudo apt-get install -y ibus-hangul

Then you need to set it up under language e region settings, choose Korean (Hangul).

Second Part - Configure Onboard:

For that you will need a skin for your virtual keyboard to display Hangul characters. I found one here:

https://forum.ubuntu-kr.org/viewtopic.php?t=15696

Download the tar.gz file and add it to the layout options on Onboard.

If you need further assistance, let me know.

4
  • Thanks, I was able to have the hangul letters show up in the onboard keyboard (together with latin), but when I click those letters, I still only get the latin characters. I do not want to change my whole system to Korean, I want to keep my English system but be able to use onboard to enter Korean characters when needed. Maybe even mix Latin and Korean in the same text. This should be no problem at all using Unicode?
    – jpp1
    Aug 28, 2021 at 14:27
  • Update: I now switched from the Mate manager to the xfce4 manager (after following the steps in this answer) and while there are still quirks, I was able to produce Hangul characters! (using Ubuntu 20.04)
    – jpp1
    Sep 9, 2021 at 9:55
  • I hate how all these solutions rely around ibus. I'm understanding more and more that it's an unavoidable requirement for these types of languages, but as someone who really prefers no dead keys norwegian to be the main layout, ibus just makes life kinda miserable. The best I could do is using the built-in input framework to define the default layout, but at that point... It's just an overcomplicated mess. Really wish the built-in input manager with korean keyboards just... worked. There's even an option for switching to hangul (at least on Mint), but it doesn't seem to do anything Nov 14, 2021 at 22:29
  • Probably just how input works on Linux though. I might just need to bite the bullet at this point, but it's just frustrating that it's this "complicated" or backward or whatever to get these languages working. You'd kinda think it'd be possible to use the built-in input system for, well, system input regardless of the language, but I guess languages are härd. Nov 14, 2021 at 22:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.