2

I just updated my Ubuntu Desktop from 19.04 to 19.10. Then I found gnome setting won't launch for me. The problem is the same as described in this post. GNOME Settings Won't Launch in Ubuntu 19.04

Command outputs are:

$ gnome-control-center --verbose
Failed to register: Timeout was reached
$ journalctl -b |grep gnome-control-center
.... gnome-control-center.desktop[1418]: nvc0_screen_create:1107 - Error allocating PGRAPH context for M2MF: -16
... gnome-control-center.desktop[1418]: Failed to register: Timeout was reached
$ uname -a
 5.3.0-18-generic #19-Ubuntu SMP Tue Oct 8 20:14:06 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
$ gnome-control-center --version
gnome-control-center 3.34.1

I have reinstalled the package as suggested by google search, but it refuses to work. Any help is appreciated.

0

1 Answer 1

4

Finally I fixed this issue by installing Nvidia driver.

Details: For days I have been frustrated by not only the issue mentioned above, but also significantly longer boot time (from 20s to around 60s) ,and frequently hanging shutdown process. What's more, the Gnome destkop easily got frozen, I had to reset my laptop.

Then I investigated dmesg output, and spotted some errors about nouveau complained by kernel during booting. Then I realized I have not installed Nvidia driver yet. The graphic card on my ThinkPad T480s is of "Nvidia GeForce MX150" model. By default, this device uses nouveau driver.

I installed nvidia-driver-435 and rebooted. All set now. My 19.10 works as good as 19.04 before.

Actually I cannot say my nvidia driver installation is complete because nvidia-smi command output indicates error.

$ nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Yet I have little knowledge of nvidia graphic card and am happy as Gnome desktop works fine as before (and 19.10 now boots and shuts down smoothly).

I have also found two workarounds : 1. Boot with an older kernel version. 19.10 by default uses 5.3.0-19-generic, here the older kernel version options available on my screen are 5.3.0-18-generic and 5.0.0-31-generic. At least the problem with gnome setting disappears in 5.3.0-18-generic. 2. Set "nomodeset" flag in kernel. But workaround #1 is awkward to me, and workaround #2 is not recommended by some discussion threads around.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.