I am running Ubuntu 18.04.3 and changes I make to the timezone do not persist. That is, I make the change and at some point within 5-20 minutes, the clock reverts to UTC time.

I have updated the timezone using the GUI and also via the command line:

sudo timedatectl set-timezone "Pacific/Auckland"
sudo dpkg-reconfigure -f noninteractive tzdata

I've also played around with the "Automatic Date/Time" and "Automatic Timezone" settings and it doesn't make any difference whether they're on or off.

I can't find a report for anything similar when searching for this issue online.

Any suggestions for how to investigate or fix this would be appreciated.

  • Do you have location services disabled?
    – mchid
    Oct 21, 2019 at 0:13
  • Also, is your computer "dual boot"?
    – mchid
    Oct 21, 2019 at 0:14
  • Location services was disabled. I turned it on, reset the timezone and again it reverted after about 10 minutes.
    – EdK
    Oct 21, 2019 at 23:22
  • Computer is not dual boot, just a Ubuntu installation
    – EdK
    Oct 21, 2019 at 23:22
  • 1
    Yep, I'd seen all of that and decided it wasn't relevant to my specific problem. Turns out that it seems to have resolved, now, though can't particularly understand why. But thanks for your efforts.
    – EdK
    Oct 24, 2019 at 3:55

1 Answer 1


According to this article:

You don't need the sudo dpkg-reconfigure -f noninteractive tzdata command and it makes me wonder if it harms things.

Basically just use:

$ timedatectl # lists your current time zone

$ sudo timedatectl set-timezone "Pacific/Auckland"

$ timedatectl # lists your new time zone

If time zone reverts back to UTC, use this command:

sudo dpkg-reconfigure tzdata
  • I have tried just the timedatectl method but this only lasts for a few minutes, as described. I found somewhere the dpkg-reconfigure instruction which I understood somehow forced the changes into the system but this makes no difference
    – EdK
    Oct 21, 2019 at 23:25
  • @EdK According to the link, when you type ls -l /etc/localtime is the symbolic link to the correct time zone? Oct 21, 2019 at 23:30
  • It shows the current clock timezone. So Pacific/Auckland for the 5-20 minutes that the change persists, but then reverts to Europe/London.
    – EdK
    Oct 22, 2019 at 20:51
  • I'll try to figure out the process changing the symbolic link. Oct 22, 2019 at 21:37
  • Similar to what you tried before, can you try sudo dpkg-reconfigure tzdata with no other options. Oct 22, 2019 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.