So I installed 19.10 fresh from USB. I picked no login required. First reboot after install I'm welcomed inside Ubuntu. But second time I'm prompted to login for no reason. Worst part is that i login with right password and all but it just loops me back to the login screen again. If I enter wrong password, it tells me I'm wrong. Tried to login via terminal and then type "sudo startx". That just led me back to login screen.

Please help me, I'm running a first gen amd ryzen and nvidia 980ti.

Edit: SOLVED! In my answer below.

  • Early ryzen processors were recalled due to a Linux compatibility problem. Users were given a free replacement. Google it and see if yours is one of those. Also, did you use sudo in the terminal?
    – heynnema
    Oct 20, 2019 at 22:17
  • Hum that bug seems like a more the possible reason. I might try the test tomorrow.
    – Huux
    Oct 20, 2019 at 23:03
  • Add your answer to a new post (you can reply to your own post, just look at the end of the page), and mark it as the correct answer. Oct 23, 2019 at 15:59

4 Answers 4


I had this issue after upgrading from 19.04 to 19.10.

The solution that worked for me is to switch display manager from GDM3 to LightDM.

If you have installed the lightdm package, just run sudo dpkg-reconfigure gdm3 and select LightDM.

After rebooting you should be able to log in.

I have since found a solution to fix login loop without changing GDM3 to LightDM:

  1. On the login screen, press Ctrl+Alt+F3.

  2. Log in to the shell using your username and password.

  3. Uninstall and reinstall the gdm3 package:

    sudo apt-get purge gdm3
    sudo apt-get install gdm3

Now just select GDM3, and after a reboot it should work fine.

  • This got me going again (updated solution) thanks heaps! Oct 30, 2019 at 21:46
  • apt > apt-get
    – Det
    Nov 19, 2019 at 16:08
  • Solved my issue as well on a clean install
    – iopq
    Nov 19, 2019 at 16:27
  • First suggestion worked for me, second suggestion did not
    – aez
    Nov 26, 2019 at 14:39
  • Far from a clean install, but the second solution worked for me.
    – Jos
    Jan 1, 2020 at 21:28


That's a problem related to the NVIDIA Kernel Module failing with proprietary drivers. To solve it, do the following steps:
  • At the login screen, press ctrl+alt+f2 to enter the terminal and login with your name and password
  • Type sudo nano /etc/default/grub (you can change nano to the text editor of your preference) to edit /etc/default/grub
  • Change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"
  • Save the edition pressing ctrl+o and exit pressing ctrl+x
  • Update this grub edit with sudo update-grub
  • Install lightdm using sudo apt-get install lightdm
  • Reboot typing sudo reboot
  • 1
    (1) Should it be "nomodset" or "nomodeset" ? (2) Nano write-out command is ^o not ^c. (3) Can't install lightdm, as there is no network in recovery terminal mode.
    – Sri
    May 1, 2020 at 10:14

Try to boot in recovery mode (if grub does not show a menu hold shift key while booting). And then remove a gnome shell extension as explained in this answer :

Login loop after upgrading to 19.04

if it does not work, in grub menu press e key to edit boot menu option add nomodeset as kernel parameter at the end of the line which has "Linux" in it.

Linux /boot/vmlinuz... nomodeset

press Ctrl+x to boot.

  • Tyvm for your answer. But I'm about to give up. I tried to ctrl + alt + f2 my way into the grub config. Tried to sudo vi /etc/default/grub and change GRUB_TIMEOUT=10 and - 1 but it seems like I can't get inte to grub menu. Changed GRUB_TIMEOUT_STYLE=hidden to GRUB_TIMEOUT_STYLE=menu without any success. Tried to press shift, f1 and esc after bios. Esc gives me grub bash. But that's not what I want. Also I tried to uninstall those gnome packages and that did not work either.
    – Huux
    Oct 20, 2019 at 22:04
  • 1
    @Huux Did you run update-grub after editing /etc/default/grub?
    – jake
    Oct 21, 2019 at 5:11
  • @jake thank you, missed to do that!
    – Huux
    Oct 21, 2019 at 8:51
  • So it seems like grub does not save the nomodset addition at boot. But I finally found a workaround and I will say that gerdiz answer helped me towards that solution!
    – Huux
    Oct 21, 2019 at 8:53

After installing lightdm display manager and rebooting, I was able to login just fine.

 sudo apt-get install lightdm

System Specifics:

OS: Ubuntu 19.10,  Kernel: 5.3.0-19-generic
       description: VGA compatible controller
       product: TU104 [GeForce RTX 2080 Rev. A]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
Display Manager: Gnome Display Manager (GDM)
Driver: nvidia-driver-435

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .