Is there anyway to fix Ubuntu 19.10 for mouse & keyboard functionality on the Raspberry Pi 4 Model B? I can't even get the Ubuntu 19.10 login when the login pops up. I can only change the password when I switch to the Raspberry Pi 3 Model B+. The original image came from cdimage.ubuntu.com/releases/19.10/release/ubuntu-19.10-preinstalled-server-arm64+raspi3.img.xz from 64-bit for Raspberry Pi 3 and 4 link "Download the Ubuntu Server image" with website ubuntu.com/download/iot/raspberry-pi.


If you don't want to wrangle patches or wait for them to be released, a workaround may be found in this thread, in one of leggazoid's posts of 10/20:


Here's the good part, which worked on my 4GB Rpi 4 [edited for clarity]:

Set total_mem=3072 in /boot/firmware/usercfg.txt
(If you mount the sd card in another computer, the usercfg.txt is on the small vfat partition.)

Ubuntu 19.10 arm64 on a Raspberry Pi 4 does not recognize a keyboard which works successfully on the same Raspberry Pi 4 with Ubuntu 19.10 armhf.

Setting total_mem=2048 in /boot/firmware/usercfg.txt allowed me to boot Pi4 4GB with 19.10 64bit with working USB. Of course I have less RAM now, but working USB.

Quoted from https://bugs.launchpad.net/ubuntu/+source/linux-raspi2/+bug/1848790

Earlier in launchpad report was

The USB-problem concerning the Raspberry Pi 4GB RAM model might be due to the issue seen earlier that using more RAM than 3072 MB breaks the USB: https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=246766&start=25

The issue was solved by a kernel patch: https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=246766&start=50#p1517839

and the kernel patch was this one: https://github.com/raspberrypi/linux/issues/3093#issuecomment-520269280

Your alternative is to use the armhf architecture.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.