2

I run a Thinkpad T460p with an Intel 9260ac wifi card. 19.04 ran great.

I upgraded to 19.10 (and I get the same from the live version) and as soon as there is any significant traffic on the wifi, the system goes to a crawl, freezes, unfreezes and then the trackpad/trackpoint become choppy and I will have to open a terminal (outside X) and reboot.

This is the journal.

Initially I thought this was a hardware error. After all that's how the log starts:

Oct 20 01:51:16 weywot kernel: iwlwifi 0000:03:00.0: Start IWL Error Log Dump:

But wifi is flawless in windows, and works fine with 19.04.

So I went for the firmware. There are 5 iwlwifi-9260-th-b0-jf-b0-XX files in /lib/firmware, and firmware loads ok.

I was able to find newer versions of firmware and try them all. I was able to upgrade the Bios and this limited the problem to a rather (and relatively) harmless error as in this log.

Trying individual files I found the .34 version to stop the problem altogether, so at least I now have my system working again.

Has anyone had problems with 19.10 and the 9260ac wifi?

The main part of the problem is that this exists as soon as I boot the Live version (and as such I can only install when wifi is off, otherwise it crashes).

Any advice/input would be welcome. Thanks.

  • I have the same network card in an XPS 13. Immediately after upgrading to 19.10 the wireless card couldn't detect any networks. After rebooting the Wi-Fi settings don't even detect an adapter – Jeremy Oct 27 '19 at 20:59
  • Yeah, I'm using the AC9260 chipset as well and ran into the identical problem. It is definitely kernel based and spans Fedora 31, OpenSUSE, and Ubuntu 19.10 (and derivatives). Some trawling of the mailing lists shows that Intel is aware of it, though it still seems a "try this" sort of thing - I don't get the sense that it's been nailed down precisely, which isn't encouraging. – auslander Nov 18 '19 at 3:00
2

For now, here's a solution that seems reasonably stable for me on Ubuntu MATE 19.10 with kernel 5.3.0-19:

  1. Copy the 9260 firmware microcode version 34 from wireless.wiki.kernel.org to /lib/firmware.

  2. Put the following line in /etc/modprobe.d/iwlwifi.conf:

    options iwlwifi power_save=0 11n_disable=1
    
  3. Reboot.

|improve this answer|||||
  • Today I tried this, I had a newer version of the firmware than the one mentioned (iwlwifi-9260-th-b0-jf-b0-46) but it appears that the options in step 2. still helped solve the issue for me, at least a first glance I'm no longer seeing the issue. – Ray Jan 22 at 17:19
  • Yes this is still the only easy fix that I know of, unless you want to manually revert back to an old kernel for me 5.2 worked fine when I tested, as also stated in this post reddit.com/r/Ubuntu/comments/dkhgg3/… recently. Someone also mentioned that intel fixed the issue which should reflect in some future updates. – rahduro Jan 22 at 23:59
0

This is a bug between the new kernel (5.3) and the network card. Seems all we can do is wait, since there are no older kernels available for Ubuntu 19.10. There is a relevant bug report here.

|improve this answer|||||
0

Just a heads up: you can cause this problem in Ubuntu 19.04 as well if you attempt to install the newer drivers for 19.10.

I was able to work around the issue by using the suggestion above:

sudo nano /etc/modprobe.d/iwlwifi.conf

And add:

options iwlwifi power_save=0 11n_disable=1
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.