4

If I try to boot normally, it just hangs on the purple screen and doesn't get to asking me for my disk encryption password.

If I go to "Advanced Ubuntu Options" (or whatever it's called) in GRUB, and try to boot with the 5.3 kernel I see the error

[   0.794343] [drm:drm_calc_timestamping_constants [drm]] *ERROR* rtc 66: Can't calculate constants, dotclock = 0!

the error number seems to change every time, but the error message is the same.

If I boot 5.3.0 in recovery mode, it seems to boot to the read only filesystem just fine, but when I ask it to continue the boot process it hangs with just a blinking underscore right away.

I can use my system just fine if I chose to boot it with the old 5.0.0-32-generic kernel through GRUB (I'm typing this bug report on "Ubuntu 5.0.0-32.34-generic 5.0.21").

During the upgrade I got an error that it couldn't start sshd because it was already running on port 22.

I've tried reinstalling the latest kernel with sudo apt install --reinstall linux-generic but that didn't help.

  • 1
    I don't have enough reputation to make a comment, so sorry in advance, I am in the same train and did what you tried also, the only difference is that as soon as it was installed I ended up with a blinking purple monitor. After reinstall the kernel I ended up with a purple freezed machine. Then I followed another answer that claimed to solve the issue in a previous Ubuntu release deleting all the kernel files and reinstalling it. Which I did and now after some minutes waiting ended up with the classic initramfs prompt, but I can – George Oct 24 '19 at 17:14
  • I just booted into an old kernel and have made sure to not reboot my computer since I wrote that question. I see that since then I got an updated kernel, 5.3.0.19.22 instead of 5.3.0.18.something. I'm hoping whenever I have to reboot that will have solved my problem... – Boris Oct 24 '19 at 17:29
  • I saw somewhere a suggestion to upgrade your motherboard's BIOS because it might be an Intel microcode issue. (the usual procedure is figure out what motherboard you have, Google "update <motherboard model number>", get an update file from the manufacturer, unzip it, plug in a USB drive with no files on it, put the files on the USB drive, reboot while mashing all the function keys, then find the "Update" action in your BIOS's menu. – Boris Dec 11 '19 at 14:59
3

I've just updated to 19.10 and had similar issue. It didn't started successfully after the automatical revoot triggered by the system update.

I restarted, chose advanced options in grub and continued with the previous kernel version (was something like 5.0.0....) When it started I run:

sudo apt-get upgrade

It failed and asked me to run:

sudo dpkg --configure -a

manually, because of unfinished configuration.

That is what I have done and after:

sudo apt-get upgrade

finished successfully I was able to restart normally.

Hope this can help somebody else who faces the same problem.

| improve this answer | |
1

I'm having a similar problem. I believe it's tied to my AMD GPU. When I select the INtel GPU (via kernel parameters) the 5.3.x kernel is fine, but when I try to use the AMDGPU, the process freezes at the Plymouth boot screen.

I suspect the kernel parameter has changed, but I can't figure out what the new one may be. Here's what I'm passing now:

ro acpi=force quiet splash i915.modeset=0 radeon.modeset=1

If you have dual GPUs, try selecting the other one.

| improve this answer | |
1

Was having the same here, on my new i3-8100. I believe it would affect most recent i3 and i5 without a grphical card, as these CPU have their own graphics integrated: HD 620, 630. Maybe it affects lots more people... don't know.

All new distros release was not working because of this for me.

This bug have appears between version 5.3.0 and 5.3.3 inclusively. I know it because I tested latest 5.2 (5.2.21 and it is not affected).

This bug have been fixed in version 5.3.8. I know it because I tested versions before 5.3.8, like 5.3.7, and it is affected.

At this stage, if you are affected by this, I would suggest you install latest kernel version (5.4-rc5 now). Maybe you should prefer 5.3.8, as it is the latest and first fixed version that is not a release candidate.

But to be able to fix it, it would be good you see what you do. When booting, press "shift" (to see the Grub menu... not sure this works!). When you are on the line to boot your kernel, press "E" to edit the lines. Go to the line that begins with "linux" go to the end and add "nomodeset". Then press "Ctrl-X" to boot your modified version... your changes will not be saved. Don't think there is a was to save it that way. Except by modifying /etc/default/grub file once you have booted.

Here is how I install a new kernel:

  • Create a directory where you will download the kernel packages
  • Go to: https://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D and select your kernel
  • Download in your newly created directory: all the deb files that does not contains lowlatency
  • open a terminal, cd to the directory, and "sudo apt install ./linux-*"
  • your new kernel should have been installed in Grub, reboot, go in advanced options, and select your freshly installed kernel

By example is is my directory:

paul@paul-FQ516AA-A2L-a6648f:~/Téléchargements/5.4-rc5$ ls -l
total 70388
-rw-r--r-- 1 paul paul 10900808 nov  2 13:37 linux-headers-5.4.0-050400rc5_5.4.0-050400rc5.201910271430_all.deb
-rw-r--r-- 1 paul paul  1184096 nov  2 13:37 linux-headers-5.4.0-050400rc5-generic_5.4.0-050400rc5.201910271430_amd64.deb
-rw-r--r-- 1 paul paul  8764272 nov  2 13:37 linux-image-unsigned-5.4.0-050400rc5-generic_5.4.0-050400rc5.201910271430_amd64.deb
-rw-r--r-- 1 paul paul 51219944 nov  2 13:38 linux-modules-5.4.0-050400rc5-generic_5.4.0-050400rc5.201910271430_amd64.deb
paul@paul-FQ516AA-A2L-a6648f:~/Téléchargements/5.4-rc5$ 
| improve this answer | |
0

3 months after posting this question, I rebooted my computer for the first time and looks like it's been solved in one of the newer versions of the 5.3.0 kernel

$ uname -r
5.3.0-29-generic
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.