1

I just updated to Ubuntu 19.10 on my HP Elitebook 8440p. I'm not sure about my GPU, but running sudo ubuntu-drivers devices yields vendor: NVIDIA Corporation and model: GTM218M [NVS 3100M], so I guess that is it.

I tried updating to 19.10 from 19.04, but at some point the screen went fully black (pixels on) and I decided to reboot (I did not pay much attention to the process, as I was busy). Then I got stuck at a purple screen before the login screen and thought I'd screwed up, so decided to install a fresh version formatting my computer.

After doing this, I got past the purple screen. The Ubuntu logo shows up loading (it seems distorted, as if the screen was in the wrong proportions) and then the NVIDIA logo (seems to be in right proportions). I get to the login screen (which seems right), buy after logging in I get stuck at a black screen with pixels on.

I tried some online troubleshooting by installing repositories, updating, upgrading, etc but nothing has worked so far. I can login through the console, though (just to be clear), but the GUI seems to fail. After logging in, just ctrl+alt+Fidoes not always work fori` ranging from 1 through 6 (some of them work sometimes, some don't, etc).

Any ideas on how to solve?

After changing from tty2 (reached from login screen) to another screen through ctrl+alt+F1, I got a black screen (pixels on) with cursors showing up. I tried changing to other screens randomly trying to reach login again (none of them worked) and when I came back to tty1 there was also a strip of screen showing the standby screen (with the clock and etc). After sometime, the screen turned off.

Everything works fine if I try to run Ubuntu from the bootable flash drive

  • So what is it, a "fresh" install or a borked "updating to 19.10 from 19.04" ? – doug Oct 20 '19 at 3:46
  • Ultimately it is fresh, for I gave up on the updated version and installed from scratch (formatting the hard drive in the process) – Níckolas Alves Oct 20 '19 at 3:48
0

I tried reinstalling it again (formatting the hard drive once more in the process) and it worked (at least for now).

0

I know you might have just reinstalled a fresh copy but launching in recovery mode and running dpkg worked for me

Not the answer you're looking for? Browse other questions tagged or ask your own question.