2

so I just bought a new laptop and used a bootable usb to install ubuntu 18.04 os on it. I was able to go through the install (although the touchscreen and touchpad didnt work I was able to use the keyboard to go through) and this seemed to work fine. After installing and plling out bootable usb and restarting, the message /dev/nvme0n1p2: clean, 137978/31227904 files, 3766150/124895488 blocks and it gets stuck there. I looked around and couldnt find anything that worked. The only thing I believe I have done to change my computers settings is switching from RAID SATA to AHCI SATA, but this didnt work I also tried reinstalling ubuntu after this switch but now ubuntu install gets stuck on the startup with the logo and dots underneath it. I also used a command (i dont remember it exactly, it was like sudo apt (something) nvidia*) to remove nvidia drivers, this also did not work.

Could anyone give me some advice, I would be very happy if I could get my new laptop working again.

Computer Specs

Dell Inspiron 17 7000 Series 2-in-1

Model: 7791

Display: 17.3" FHD Touch Display with Webcam

Processor: Intel Core i7-10510U

16GB Memory

Graphics: NVIDIA GeForce MX250 2GB

  • 1
    Could you try adding nouveau.modeset=0 on the kernel parameter? – jrandiny Oct 20 at 9:44
  • 1
    this totally worked @jrandiny however touchscreen and touchpad still do not work. after using less on /proc/bus/input/devices and looking through the list I do not see any input devices for either – Brandon Oct 20 at 14:24
  • Please try with the newest possible Ubuntu iso file, 19.10 or even the developing version Focal Fossa (to become 20.04 LTS in April 2020). With a new version you get a new linux kernel and with a new linux kernel you get new hardware drivers, and this may help with your new computer. – sudodus Nov 16 at 10:32
1

I have a dell Inspiron 15 7000 2 in 1 added modeprobe.blacklist=intel_lpss_pci to grub line Manage to install but no touchpad/touchscreen. not showing up in /proc/bus/input/devices either

  • 1
    Please tell us with more details what you have tried, what works and what does not work: The version/flavour of Ubuntu, what drivers and program packages that are installed/used and what you have tweaked. The information about the blacklisting is useful for us [other users], but please tell us more :-) – sudodus Nov 16 at 10:27
  • 1
    I tried with 19.10 also with no resolve. Also just tried building linux kernel from source. Didn't work ( 5.4 ) – Dell-user Nov 16 at 14:36
  • I have good experience with older Dell computers including Precision and Latitude with generation 4 intel i7 and i5 CPUs. It makes me sad to read, that Ubuntu has problems with this new model, and I hope that someone can chip in with a solution. – sudodus Nov 16 at 14:43
  • 2
    I believe the solution lays here. wiki.archlinux.org/index.php/Dell_XPS_13_2-in-1_(7390) " To fix the intel_lpss_module the patch from this paste must be applied to the kernel. pastebin.com/sqPv8ShP " Probably the same chipset. – Dell-user Nov 16 at 15:43
  • Great news :-) I suggest that you update your answer with the content of your comments. – sudodus Nov 16 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.