1

I recently formatted my computer and bought a wireless adapter for it Archer T4U US 3.0 from tp link.

I have been trying to get it to work but at first it did not recognize the wifi adapter, so I tried this solution: https://askubuntu.com/a/802209/592069

After trying the solution I now get the symbol of wifi in the top but it does not recognize any networks from my local I have both signals 2.4ghz and 5.8ghz, but none of them work.

The main reason why I bought this new adapter is to be able to connect to 5.8ghz so that is the main frequency I am trying to connect to.

An active user from the answer that i tried before recommended me to post the results from a script that is posted in My wireless/WiFi connection does not work. What information is needed to diagnose the issue?

The result is https://paste.ubuntu.com/p/3pjxnpMzwY/

Also attaching a couple of images of how everything looks in my OS: enter image description here

enter image description here

3
+50

First, we search for your device ID, in this case, the usb.id 2357:0115. We find the usually very reliable wikidevi: https://wikidevi.com/wiki/TP-LINK_Archer_T4U_v3 It suggests that the correct driver is not rtl8812au but 88x2bu. I suspect that rtl8812au was correct for an earlier version of the T4U; v2 or v1, perhaps. I am surprised that the rtl8812au driver works even partially.

Let's install the probable better driver:

sudo apt update
sudo apt install dkms git
git clone https://github.com/cilynx/rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959
sudo dkms add ./rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959
sudo dkms install -m rtl88x2bu -v 5.3.1
sudo modprobe -r rtl8812au
sudo modprobe 88x2bu

If the wireless works as expected, let's blacklist the incorrect driver:

sudo -i
echo "blacklist rtl8812au"  >>  /etc/modprobe.d/blacklist.conf
exit
  • is it possible to use make clean and then make instead of dkms? I have no internet connection to install with sudo apt sadly. I also tried downloading the .deb package for bionic but it is not found when executing it in the terminal. – Enmanuel Durán Oct 19 at 21:08
  • I have used sudo make and sudo make install instead of using dkms and it just worked like a charm, thanks a lot, you have no idea how helpful this was. – Enmanuel Durán Oct 19 at 21:31
  • Now that you have internet connectivity, I recommend that you undertake the dkms process so that you needn't recompile with every kernel update. Glad it's working! – chili555 Oct 19 at 21:33
  • Done, your steps with dkms worked properly. – Enmanuel Durán Oct 19 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.