7

In the new version 19.10 my grub file is:

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=4
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Despite this at boot I don't see the grub menu nor does it wait 4 seconds. How I can fix it?

12

Edit /etc/default/grub (sudo -H gedit /etc/default/grub)...

change:

GRUB_TIMEOUT_STYLE=hidden

to:

GRUB_TIMEOUT_STYLE=menu

then save the file and quit the editor. Next run:

sudo update-grub 

GRUB_TIMEOUT_STYLE

If this option is unset or set to menu, then GRUB will display the menu and then wait for the timeout set by GRUB_TIMEOUT to expire before booting the default entry. Pressing a key interrupts the timeout.

If this option is set to countdown or hidden, then, before displaying the menu, GRUB will wait for the timeout set by GRUB_TIMEOUT to expire. If ESC is pressed during that time, it will display the menu and wait for input. If a hotkey associated with a menu entry is pressed, it will boot the associated menu entry immediately. If the timeout expires before either of these happens, it will boot the default entry. In the countdown case, it will show a one-line indication of the remaining time.

  • thank you, it works! – Lilia Oct 19 at 16:03
  • +1 but you may want to repeat your answer on the duplicate I just nominated. Thanks. – WinEunuuchs2Unix Oct 20 at 15:32
  • @WinEunuuchs2Unix Done. Thanks! – heynnema Oct 20 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.