I was running a dual boot system with Windows 10 (2019 May version) and Ubuntu 19.04. Both systems are UEFI secure booted. In Ubuntu 19.04, all drivers except Nvidia GPU were installed with those came with 19.04 installation package. The Nvidia GPU driver was separately downloaded from PPA and signed by MOK.

Yesterday I upgraded Ubuntu 19.04 to 19.10 by update-manager -d. After automatically reboot, I found I cannot normally boot into Ubuntu from Grub. It stuck at a purple screen, with a black box printed: UEFI Stub: Secure boot enabled.

What I tried:
1. From advanced options in Grub, I found Ubuntu 19.10 cannot be booted using kernel 5.3 but was bootable using kernel 5.0.0-32.
2. I tried to add nomodeset to grub options but still stuck at the purple screen when normal boot.
3. I tried to disable secure boot from BIOS but still stuck at the purple screen when normal boot.
4. I tried to uninstall Nvidia-driver by booting into kernel 5.0.0-32 and made sure the driver for both kernels 5.3 and 5.0 were removed. But I still stuck at the purple screen when trying to normal boot.

What happened and what should I do to make kernel 5.3 usable? Thanks!

Sys Info:
Core X i9-9820X, ASUS Prime X299 Deluxe II, 128GB RAM, Nvidia GTX 1650 + Nvidia Titan RTX, 256GB SSD + 1TB SSD + 4TB HDD + 8TB HDD.

  • Have you tried disabling Wayland? This seems to work for similar issues happening on 19.04 (see askubuntu.com/a/1175428). That said, I am having a similar problem as you, and it did not work for me :( Good luck!
    – Jorge
    Oct 18 '19 at 23:44

I'm the PO of this post and I've fixed the booting problem by updating the BIOS to the newest version.

My previous BIOS is the 2019 July version, but the lastest on ASUS website is the 2019 October version which adds support for Core X 10th generation (my CPU onboard is from the 9th generation).

I'm not sure how it has helped the booting problem, but it has made the kernel 5.3 bootable through the new GRUB. Maybe it's about the intel-microcode and it's an ASUS or X299 specific problem?

  • I have a recent model desktop ASUS motherboard, and upgrading the BIOS fixed it for me also. Dec 4 '19 at 8:58
  • I faced also this issue after a simple upgrade on xubuntu 18.04 LTS. When I selected the ubuntu partition in GRUB, my screen stayed blank black and nothing was booting. I tried for one day thousand different ways to twist grub or X, but nothing fix it. I finally dist-upgrade to xubuntu 20.04 LTS in recovery mode. The upgrade did not fix the boot issue but at least I get this new error message "UEFI Stub : Secure boot enabled" which led me to this post and I try to update the BIOS of my ASUS UX305CA. it is now fixed! And my laptop is working like a charm. Thank you !
    – ced
    Dec 5 '20 at 11:47

Looks like grub is a mess in 19.10. There're multiple bug reports of bootloader install failures and boot failures in launchpad. Even Windows EFI boot is affected when Secure Boot is disabled, see:

https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1839317 https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1845289

Given that these 2 bugs could be worked around by downgrading grub to 2.02 from disco you can try this as well.

  1. Boot using kernel 5.0.0.
  2. Download required packages from https://packages.ubuntu.com/source/disco/grub2
  3. Backup all your custom grub configs
  4. Downgrade packages

This may help, but if it doesn't you can also try the following:

  1. Wipe out your grub installation by removing packages and leftover files, like /etc/default/grub, /boot/grub and /boot/efi/EFI/ubuntu
  2. Install packages from disco
  3. Change configs for your specific use case

I recommend to prepare live usb with ubuntu 19.10 or 19.04 before doing these modification in case of boot failures so you'll be able to reinstall grub from eoan and restore your backup configs.

  • Thanks Xeron. My situation seemed to be a bit different. I could boot Windows 10 Pro and Ubuntu kernel 5.0 without problem but I couldn't boot kernel 5.3. Now I've made kernel 5.3 bootable by updating my BIOS to the latest version just published by ASUS. I'm not sure how that has helped though. My previous BIOS was only one version behind, which I just updated in July.
    – Dadi Gao
    Oct 22 '19 at 16:26

I went to the same problem recently in ubuntu 19.10(dual boot win 10) with nvidia 1650 i7 Lenovo legion 540 after bios update . After trying all possible solution it did'nt work. So finally i removed ubuntu 19 completely from disk first and then fresh installed ubuntu 18.4.

link in description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.