0

I am quite new with linux (only experience from school 10 years ago) and I am trying to set my new server with OS Linux which will act as an application server at home. I have already my own network in place with Rack where are network devices and I want to have this server there also, so I want to access this server only remotely via xrdp or vnc (of course with SSH) from my Windows desktop.

I have completely fresh version of Ubuntu Desktop 19.04 installed with minimum option. I tried every possibly way (also full instalation version of Ubuntu 19.04) - I mean I go through and follow many and many instruction how to make it work, but nothing helped. I always get Grey screen. So I re-install Ubuntu again and some advice will be really helpfull how to access this Ubuntu via VNC. Currently, I have really simple configuration so that you know (I hope) how to resolve it.

VNC VNC server on ubuntu desktop 19.04: petr@Odin:~$ sudo apt install tightvncserver petr@Odin:~$ sudo tightvncserver (pswd set)

VNC client at windows tightVNC -> the latest 64bit version

Log:vnc_log

xstartup

!/bin/sh

xrdb $HOME/.Xresources xsetroot -solid grey

x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &

x-window-manager &

Fix to make GNOME work

export XKL_XMODMAP_DISABLE=1 /etc/X11/Xsession


regarding xrdp it works, I can access it, but it seems that when i rdp to ubuntu I dont have all access rights with comparsion when I am connected directly, for example I cannot change some settings, enable/disable wifi, etc.. also I have to almost every action confirm by my password, it is really annoing. If it can be changed, then I dont need VNC, but currently it is horrible. Dont you know how to change it?

I am sign as petr@Odin:~$ , so superuser is created (it was done during instalation)

could someone help me please? I am fighting with 3 days with still the same results..

0

xRDP could be the way to go... the problem you are facing is due to polkit technology. When you are working on a remote session, polkit does not authorize all actions indeed... (you can have a quick idea of polkit limitation and xrdp via this post (http://c-nergy.be/blog/?p=120731)

So, to have all the necessary rights you might need, you have multiple options

  • you can disable polkit - Not recommended
  • you can create a list of exceptions for the actions you would need to do and configure if authentication popup would be presented or not

you can find some examples of polkit exception files that are used when working with xRDP reading these posts

http://c-nergy.be/blog/?p=14051

(http://c-nergy.be/blog/?p=120731)

hope this help Till next time

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.