0

I have seen a few posts on here about the Matebook D and have tried a couple of the solutions but so far nothing seems to have worked. I'm running Ubuntu 19.04 (18.04 until a week ago). I've updated the kernel to 5.3.7. Through my windows partition I've ensured that the BIOS is updated (1.22 I believe). I still find that on chromium browser it will freeze anywhere from 1 minute to 1 day. It seems to happen more often on JS-heavy websites which involve a lot of content auto-loading eg. facebook. In the logs I've got:

09:49:50 bluetoothd: Failed to set mode: Blocked through rfkill (0x12)
09:49:50 spice-vdagent: Cannot access vdagent virtio channel /dev/virtio-ports/com.redhat.spice.0
09:49:46 gdm-session-wor: gkr-pam: unable to locate daemon control file
09:49:19 systemd: Failed to start Postfix Mail Transport Agent (instance -).
09:49:17 dhclient: Timeout too large reducing to: 2147483646 (TIME_MAX - 1)
09:49:16 bluetoothd: Failed to set mode: Blocked through rfkill (0x12)
09:49:16 spice-vdagent: Cannot access vdagent virtio channel /dev/virtio-ports/com.redhat.spice.0
09:49:12 bluetoothd: Failed to set mode: Blocked through rfkill (0x12)
09:49:12 kernel: kvm: disabled by bios
09:49:11 systemd: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video1.
09:49:11 kernel: kvm: disabled by bios
09:49:11 kernel: kfd kfd: device 1002:15dd NOT added due to errors
09:49:11 kernel: kvm: disabled by bios
09:49:11 kernel: snd_pci_acp3x 0000:02:00.5: Invalid ACP audio mode : 1
09:49:11 kernel: Couldn't get size: 0x800000000000000e
09:49:11 kernel: MODSIGN: Couldn't get UEFI db list
09:49:11 kernel: Couldn't get size: 0x800000000000000e
09:49:11 kernel: tpm_crb MSFT0101:00: can't request region for resource [mem 0x8f7a6000-0x8f7a9fff]
09:49:11 kernel: pci 0000:00:00.2: AMD-Vi: Unable to write to IOMMU perf counter.
09:49:11 kernel: AMD-Vi: Disabling interrupt remapping

Anyone have any suggestions on what I can do to stop this happening? Let me know if I need to provide any more info

0

It seems there is a ton of issues on IOMMU with the ryzen processors. I also faced it. Try to add the following option to /etc/default/grub at line GRUB_CMDLINE_LINUX_DEFAULT:

iommu=soft

Then run

$> sudo update-grub

Finally reboot

3
  • thanks for your response. Just to be clear the line already reads GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" so you're saying add rather than replace right: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash iommu=soft" ?
    – DavidM
    Oct 20 '19 at 9:00
  • So far this seems to have worked! Just going to give it to the end of the day before I give it a thumbs up
    – DavidM
    Oct 22 '19 at 10:49
  • In the end I used a combination of iommu=soft and processor.max_cstate=1, and upgraded to 19.10. This seems to have fixed it. So thanks to both answers!
    – DavidM
    Oct 30 '19 at 17:07
0

Try add to kernel boot options something like this:

processor.max_cstate=1 // or 5
1
  • would this also mean editing GRUB_CMDLINE_LINUX_DEFAULT in the grub file?
    – DavidM
    Oct 20 '19 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.