entered the command for updating to 19.10 from 19.04

As you can see in the image above, I tried to update to 19.10 and it says that

No new release found

I checked the /etc/update-manager/release-upgrades to see if the Prompt is LTS but it is still normal.

What would be your advice?

UPDATE: I already updated the system to 19.10. Thank you very much for the advices.

  • the same thing happened to me a couple of hours ago, their server are most likely getting too many requests, so if I were you would just try to upgrade every few hours till it works out. Oct 17, 2019 at 21:18
  • 6
    It can take several days for all the changes to propagate, world-wide.
    – K7AAY
    Oct 17, 2019 at 21:28
  • 1
    I wouldn't want to be the first one upgrading anyway. I would wait a week after everyone else to see what different bugs are reported and if they might affect me. Oct 17, 2019 at 21:48
  • Kubuntu 19.10 has been released (64-bit only). Download it here: kubuntu.org/getkubuntu. This question is off topic because it seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers.
    – karel
    Oct 18, 2019 at 10:19

5 Answers 5


Upgrades from previous versions are only switched on by the release team when they are are happy that there are no massive upgrade bugs hiding anywhere.

In the past, this has varied from enabling them later on the actual release day, all the way to nearly a week after release. There is absolutely no fixed rule.

In the case of this release, when I queried with Adam Conrad (Ubuntu Release Team) on IRC on Friday 18th October, I was told that they were vaguely undecided on whether to 'just do it' that day or 'maybe wait for a weekend of potential bugs to roll in and re-evaluate on Monday'. Obviously the latter won out.

As have been explained you can force the upgrade by appending '-d' when manually running the release upgrade tools. This has the effect of making the release upgrader check against this development release meta file where Eoan is still the development release and upgradable to, instead of the proper stable release meta file where it has not been added yet. If you do so before before the release team decide to pull the trigger, you are basically becoming an at your own risk tester of this process.

Rik Mills.

K/Ubuntu Developer

  • This should be mentioned anywhere do-release-upgrade is mentioned. It's not that far fetched to imagine that that command will be run a little more often immediately following a release.
    – Andreas
    Apr 23, 2021 at 12:26

It will appear one week after the release. Until then it still is considered a "development" release. You can get it anyways when specifying -d:

do-release-upgrade -d

enter image description here

Source: Ubuntu Tutorial

Looks like you need to wait a few days, or force the update with the -d flag


For me, also, sudo do-release-upgrade -c reported no new release.

So, next I tried upgrading 19.04 to 19.10 using
sudo do-release-upgrade -d (instead of -c)

The good news is this resulted in an upgrade to 19.10 after a couple of hours with brief pauses for permission to use distribution versions of a couple of files instead of my customized versions. However, the bad news is that I had no GUI login prompt after the upgrade. I could SSH in remotely but could not login locally. I tried fixing the problem manually and it didn't help.

Next, I tried this again on another computer. The end result was the same as the fate of the first computer.

After that, I restored the two computers from the backups I made just before attempting the upgrades. Both computers are back on 19.04 and are working properly. I will try again in a few weeks.


I found a solution and want to share it.

The issue was that I had no GUI login prompt after the upgrade from Ubuntu 19.04 to 19.10.

The actual problem turned out to be that the GUI login prompt doesn't appear if Wayland is enabled on Ubuntu 19.10 and Ubuntu is running on Virtual Box on Windows 10 just.

My solution was to get into Ubuntu desktop by ssh, then edit /etc/gdm3/custom.conf, uncomment WaylandEnable=false in the [daemon] section, and reboot. And with that, I got the GUI login prompt and was able to login and enjoy Ubuntu 19.10.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .