3

I just upgraded to Ubuntu 19.10. Upgrade was done via update manager GUI. I am using nvidia as a graphics driver.

After upgrade I get logged in but I get this screen:

enter image description here

How do I troubleshoot this?

I ran sudo dpkg --reconfigure -a. This resolved the first problem, but now I am at the login screen and unable to login.

I have looked at this question here:my .xauthority and .iceauthority permissions are correct although .xauthority is 0KB. /tmp permissions are also correct. I don't have lightdm installed.

I have also checked the Xorg.log and .xsession log. Renamed the extensions folder as well as the .xauthority file. no luck.

enter image description here

  • Are you using wayland or xorg? – Wayne Vosberg Oct 17 at 15:47
  • I don't know. I am on the default. – user1373927 Oct 17 at 15:48
  • On the login screen where you enter your password, click on the gear and try the different options -- should be gnome, gnome on xorg, ubuntu, ubunton on wayland. Maybe others. There are some known issues with nvidia but I'm not sure if this is one or not: wiki.ubuntu.com/EoanErmine/ReleaseNotes – Wayne Vosberg Oct 17 at 16:02
  • I don't have a gear icon. – user1373927 Oct 17 at 16:05
  • Should be right next to the Sign On button. If not, you may have only one environment installed. If you can get to a console login try sudo apt-get install xorg xwayland gnome – Wayne Vosberg Oct 17 at 16:07
4

I had automatic login enabled. I just updated this file: /etc/gdm/custom.conf

and commented out these lines:

AutomaticLoginEnable=True
AutomaticLogin=username

After this I am able to login. Is this a bug?

  • worked for me - thank you! – Randomize Oct 17 at 18:08
  • Worked for me with path /etc/gdm3/custom.conf (see the 3?) – pommedeterresautee Oct 25 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.