1

I am setting up a Dell laptop with Xubuntu 18.04.2. It seems to be working with wifi and other things, but I can't play a DVD in VLC or the native Parole Media Player. Have no trouble with my other Linux machine running the same build. I've tried all the installations of the Ubuntu-Restricted-Extras, uninstalling and reinstalling it.

I did a test of the codecs and it seems that libdvdcss2 is missing, and I recall that's necessary for encrypted DVD's. Old posts recommended I typed in the commands to mediabuntu.com to get that file - it apparently no longer exists. It is a game sales web site, but perhaps their repository is gone.

I've heard about a paid codec called Fluendo, but when I go to their web site I don't see an individual purchase option - or a price! I'm only wanting to install it in one machine, not a factory run of 5000. It isn't listed in the repositories, of course. I'd be willing to buy it to try to solve the problem if Fluendo would explain how to get it, and it wasn't like $50 or something. Have you got any advice?

  • A similar post suggested I try... – tomreedtoon Oct 17 at 3:21
  • These are the codes I typed in, based on similar posts: patty@patty-Inspiron-1720:~$ sudo apt install libdvccss2 libdvdread4 libdvdnav4 ubuntu-restricted-extras [sudo] password for patty: E: Type '<!DOCTYPE' is not known on line 1 in source list /etc/apt/sources.list.d/medibuntu.list E: The list of sources could not be read. patty@patty-Inspiron-1720:~$ sudo apt install libdvd-pkg E: Type '<!DOCTYPE' is not known on line 1 in source list /etc/apt/sources.list.d/medibuntu.list E: The list of sources could not be read. Obviously, still no joy. Any ideas? – tomreedtoon Oct 17 at 3:21
  • See askubuntu.com/questions/1013292/… again. I updated for the repository that you seem to not have enabled. – Terrance Oct 17 at 3:30
  • I typed in the codes just located on that post: 'sudo add-apt-repository universe sudo add-apt-repository multiverse sudo apt update' ''universe' distribution component is already enabled for all sources.' ~$ sudo apt install libdvdcss2 libdvdread4 libdvdnav4 ubuntu-restricted-extras E: Type '<!DOCTYPE' is not known on line 1 in source list /etc/apt/sources.list.d/medibuntu.list E: The list of sources could not be read. E: Type '<!DOCTYPE' is not known on line 1 in source list /etc/apt/sources.list.d/medibuntu.list E: The list of sources could not be read.' – tomreedtoon Oct 17 at 3:42
  • You need to fix the /etc/apt/sources.list.d/medibuntu.list file. You have an error on the first line of the file. Until that is fixed sudo apt update may not work properly. See askubuntu.com/questions/96967/… – Terrance Oct 17 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.