There are lots of posts on this about Unity, this is about GNOME shell.

As with other posters, I use apps (Inkscape in particular) that uses Alt-Click and Alt-drag. GNOME shell is grabbing this off me and thus disabling features in the application.

I have tried

  • using ccsm's Move plugin - you can turn this off and you still get Alt-drag window moving.

  • using gconf editor to change /apps/metacity/general/mouse_button_modifier - this has no effect AFAICS.

It's really hindering me. Otherwise I find GNOME shell a really productive environment.

up vote 104 down vote accepted

First of all, install dconf-tools Install dconf-tools.

To do that, run the following command:

sudo apt-get install dconf-tools

Then open it, Alt+F2dconf-editor.

Scroll down to orggnomedesktopwmpreferencesmouse-button-modifier → Set it to whichever key you like.

enter image description here


Or, equivalently,

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier "<Super>"

in the terminal. (This requires neither dconf-editor, nor dconf-tools Install dconf-tools)

Warning: Setting it to nothing means that all clicks move windows, instead of disabling it!

  • 25
    Warning! Setting it to nothing means that all clicks move windows, instead of disabling it! – Andrea Oct 28 '13 at 21:15
  • 6
    I tried the dconf-editor method, but nothing seems to have happened. <ALT> is still my modifier key. I have tried "['<Control><Alt>']" (following the syntax of the keybindings options) and "<Control><Alt>". Do I need to restart in order for this to take effect? – Gordon Bean Aug 11 '14 at 17:04
  • 3
    I first tried it with the gsettings command, and it seems to have changed it successfully, but Alt+Drag would still move the window. Even after a restart. I then installed dconf-tools and confirmed with the dconf-editor that mouse-button-modifier indeed was changed, but as I said, Alt+Drag still moves windows. (I'm on Mint Cinnamon 17.2 64bit) – Bloke Sep 3 '15 at 11:15
  • 4
    "<Alt>+<Super>" value pretty works for me – vp_arth Feb 26 '16 at 10:24
  • 2
    @Bloke: I think for Cinnamon, it should be org.cinnamon.desktop.wm.preferences instead. At least that's what worked for me. – Giraldi Sep 25 '17 at 6:15

To resolve the Alt+Click move window dragging problem:

sudo gconftool-2 --set /org/gnome/desktop/wm/preferences/mouse-button-modifier --type string '<Super>'

Does the same thing, really, just with a different config tool, and less hunt-and-click.

For newer versions using dconf/gsettings, use this:

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier "<Super>"
  • 2
    gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier "<Super>" for dconf. – ulidtko Jun 24 '13 at 21:51

Use the Tweak Tool (gnome-tweak-tool):

Windows > Window Action Key

  • Thank you! This worked for me when everything using dconf-editor or the command line or compiz failed. Now I can use alt for other shortcuts and restore functionality to several programs. – Silvestris Apr 1 at 15:21

I set Alt+Super like a temporary solution. So I can use the Alt key in Inkscape and Super for activities.

  • what do you mean by "activities"? I have changed Alt to Super and it works fine for me. I did not notice any side effects. Why would you need Alt + Super? – faizal Oct 20 '14 at 8:25
  • 3
    wiki.gnome.org/Projects/GnomeShell/Tour#Activities_Overview If you set "Super" for moving windows you can't use it for show "Activities Overview". Look at posting time, it was two years ago. – KEIII Oct 20 '14 at 11:58
  • Two years is nothing. – Johan Boulé May 8 '15 at 19:25

In UBUNTU 14.04 LTS use in dconf syntax like

<Alt><Super>

Works well for me.

BTW: If you set something wrong, it starts to move window on every click. Use to navigate to "Set to Default" button. And hit .

enter image description here

In Mint this can be changed or disabled in system settings > windows > behavior > 'Special key to move and resize window'

  1. Go to System Settings
  2. Select Keyboard
  3. On the bottom left click on ‘Layout Settings’
  4. Select your language and click the ‘Options’ button on the lower right
  5. Select ‘Alt/Win key behavior’
  6. Change it to the one you like. I use ‘Left Alt is swapped with Left Win’.

in CentOS 7, I had to use

 gsettings set org.gnome.desktop.wm.keybindings activate-window-menu "['<Alt>F10']"

This setting had been unspecified, which had meant that the mouse middle button activated the window menu. Even setting

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier '<Super>'

did not move that action to Alt-middle; I had to bind activate-window-menu.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.