I have a new Wacom Bamboo Pen. I'm using Ubuntu 10.10 64bit.

After googling a little bit, I checked that xserver-xorg-input-wacom was installed. I plugged in my tablet. I rebooted my computer. Nothing special happened. I opened Inkscape. The tablet didn't work. I opened Inkscape's Input devices dialog. I didn't understand anything. I tried to blindly click some options in that dialog but nothing seemed to have any effect. Same with Gimp.

After googling some more I found the linuxwacom website with source code, this didn't seem to work.

So... any help?

As requested:

Bus 005 Device 002: ID 056a:00d4 Wacom Co., Ltd 

dmesg | tail
[  492.961267] usb 5-1: new full speed USB device using uhci_hcd and address 3
[  493.144862] input: Wacom Bamboo 4x5 Pen as /devices/pci0000:00/0000:00:1a.2/usb5/5-1/5-1:1.0/input/input6
[  493.158854] input: Wacom Bamboo 4x5 Finger as /devices/pci0000:00/0000:00:1a.2/usb5/5-1/5-1:1.1/input/input7
  • 1
    Can we please get the type of your Wacom Tablet/Pen? Also the output of lsusb, and please unplug the device, plug it back in and then post the output of dmesg | tail here. Please add/edit this directly to your question.
    – Bobby
    Nov 6, 2010 at 20:12
  • @casadraya: As a new user you're not allowed to set hyperlinks (more then one, I think) due to spam prevention. Maybe somebody with higher rep is going to edit them in for you.
    – Bobby
    Nov 6, 2010 at 20:20
  • Could you edit the post to take away the instructions to compile the driver from source? These are not good instructions and they can mess things up. Nov 11, 2010 at 21:17
  • Thank you for your efforts here. My tablet works with your PPA (CTE-440) Graphire 4 running 10.10 on a PPC machine. Thank You! It may be worth noting for Synfig users to make sure Stylus and Screen are selected in that programs preference to be in pen mode. Again thank you for your work.
    – user7872
    Jan 24, 2011 at 22:06

2 Answers 2


You need to install the wacom-dkms package from my PPA


You can do this by using the following commands:

sudo add-apt-repository ppa:doctormo/wacom-plus
sudo apt-get update
sudo apt-get install wacom-dkms

There is also an updated xorg driver for lucid available in the same ppa to fix a bunch of issues in the LTS. Please don't compile your drivers, seek help packaging them up instead so we can provide the driver fixes to everyone and hopefully fix them forever.

  • No luck with that. I did it, it installed the package, but I can't get the tablet to do anything at all. Tried rebooting also with no luck.
    – casadrya
    Nov 6, 2010 at 22:29
  • 2
    If that didn't work than you may have messed up your system trying to manually compile it. Your device is known to work with that dkms package. Could you try to get it working with another machine or install? Nov 7, 2010 at 4:10
  • I can confirm that those packages work on Ubuntu 10.10 64-bit up-to-date with the latest kernel and using a Wacom Bamboo Pen (CTL-460).
    – JanC
    Nov 7, 2010 at 4:37
  • It worked. I went to Synaptic. Reinstalled xserver-xorg-input-wacom and then reinstalled wacom-dkms. It now works at last. Thanks a lot. By the way, why isn't this package in ubuntu by default (or at least in the official repositories)?
    – casadrya
    Nov 7, 2010 at 8:23
  • It's a kernel modification, it should be synced back to Lucid and Maverick but I don't really know how to make the requests to do it yet. Nov 7, 2010 at 17:15

Works fine on bamboo pan and touch

sudo add-apt-repository ppa:irie/wacom
sudo apt-get update
sudo apt-get install xserver-xorg-input-wacom
sudo apt-get install wacom-dkms

Reboot and Enjoy !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy