1

I have Ubuntu 19 and at work I use two Exchange-type mail accounts. One is on an Exchange server and one is on Office365. I can set up both using evolution-ews and for the 'old fashioned' Exchange server it works and syncs mail, contacts, calendar, etc.

For the Outlook365 server it shows the folder pane and even shows how many new messages there are. But the message pane stays empty ("There are no message in this folder") everywhere and I get the message

Failed to refresh folder "me@myserver : Inbox"
The reported error was: "Connection terminated unexpectedly".

If I start it from the terminal I get these messages:

$ env XDG_CURRENT_DESKTOP=GNOME evolution
(evolution:9221): dbind-WARNING **: 08:56:37.994: 
   Couldn't connect to accessibility bus: 
   Failed to connect to socket /tmp/dbus-67zLohQHkE: Connection refused
(evolution:9221): Gtk-WARNING **: 08:56:38.181: 
   Failed to register client: 
   GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: 
   Method "RegisterClient" with signature "ss" 
   on interface "org.xfce.Session.Manager" doesn't exist
(evolution-alarm-notify:9227): dbind-WARNING **: 08:56:38.395: 
   Couldn't connect to accessibility bus: 
   Failed to connect to socket /tmp/dbus-67zLohQHkE: Connection refused
(WebKitWebProcess:9248): dbind-WARNING **: 08:56:38.512: 
   Couldn't connect to accessibility bus: 
   Failed to connect to socket /tmp/dbus-67zLohQHkE: Connection refused

I'm afraid I don't know what that means.

My window manager is XFCE, which I know is not the default for Evolution. But on an older computer with Debian Stretch and XFCE I have access to the account, and I have seen it work on work on Ubuntu 18 with KDE.

It seems that Ubuntu 19 makes Evolution fail with Office365? I reverted to the Ubuntu 18 repositories and deleted then re-installed evolution 3.28.5 (probably not recommended!) but that has not solved the problem.

Does anyone know if, and how, Office365 can be made to work in Ubuntu 19?

EDIT: The problem seems to be the two-stage authentication. Even though for both exchange/outlook servers I have to set the server that I use for web-mail as well, the authentication, which in both cases goes via this TIQR app on the smartphone, still lets one of them work in Evolution/Gnome Online Accounts but not the other.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.