3

I have gotten my system into a state where there are no Gnome users with account type "Administrator" all the users are "Standard."

Note: Gnome Administrator is not the same thing as sudo.

I can login fine and I can run sudo successfully from a terminal, but I can not unlock any settings in the Gnome GUI or update/install applications, connect to networks, etc... from the GUI.

I understand that the "normal" way to add a new Administrator is with an an existing Administrator via the GUI. The first user created on the system is an Administrator, but that user has been deleted. So there are no Administrator users.

My understanding is that there is some way to use dconf or gsettings or both to make the current user a user of Account Type "Administrator" but I can't seem to figure out how.

Question: How do I make a user "Administrator" for the Gnome GUI if no users are Administrators given that I DO have sudo.

1
+50

Add the user to the adm and sudo group.

sudo usermod -a -G adm <username>

sudo usermod -a -G sudo <username>

At least this works for me in Gnome 3.12 . It is similar as it was for Unity sudo & admin groups, referenced here: How to manage users and groups using GUI?

Looking at the Security/Privileges page on the ubuntu wiki you can find what various groups mean. Also there is a list of groups added to the first user.

In a default Desktop installation, the first user on the system is considered an administrator, and as of Ubuntu 10.04 LTS is a member of the following groups: adm, dialout, cdrom, plugdev, lpadmin, admin, sambashare

Setting these groups will give you Administrator in Gnome.

1

Nothing found with become GNOME Administrator CLI commands but the first link found with a web search on become GNOME Administrator revealed https://help.gnome.org/users/gnome-help/stable/user-admin-change.html.en which explains the first user account on the system is usually the one that has administrator privileges. This is the user account that was created when you first installed the system. So, instead, try this with other accounts on your system:

  • Open the Activities overview and start typing Users.

  • Click Users to open the panel.

  • Press Unlock in the top right corner and type in your password when prompted.

  • Select the user whose privileges you want to change.

  • Click the label Standard next to Account Type and select Administrator.

  • The user’s privileges change when they next log in.

Please try that process and if it does not work, please click [edit] for your question and so advise.

  • Ubuntu uses Gnome as part of its operating systems. To unlock settings in the GUI you have to be a Gnome Administrator. As shown in the Settings -> Users Panel. I have sudo, I do not have Gnome Administrator. – Victory Oct 17 at 5:00
  • @Victory Edit your question to expand it. – K7AAY Oct 17 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.