1

I have Ubuntu 19.04. I want to change the shortcut key for Switch to next input source to Alt+Shift. I go to the Keyboard section in Settings and find the entry (under Typing). When I click on it a dialog appears, and says "Enter new shortcut..." with a keyboard picture under it. However, when I hit Alt+Shift it is dumbly not responding.

The current shortcut is in gray color as I thought it's disabled and I don't have the privilege to change it. Accidentally, I hit Alt+PrintScreen and it responded that it is assigned to another command, but for Alt+Shift it even doesn't guide me what the problem is. How can I solve this?

  • You can't set <Alt>+<Shift> that way. Use Tweaks instead. – Gunnar Hjalmarsson Oct 15 at 16:30
2

For Ubuntu 19.04 use the following method:

  • Run gnome-tweaks command (without sudo of course)
  • Select Keyboard & Mouse
  • Click Additional Layout Options
  • Expand Switching to another layout
  • Select the checkbox at the left of Alt+Shift

After that, if you want to check the change:

  • Go back to Settings and select Region & Language
  • Click the gear icon ⚙ to the right of Input Sources to display the Input Source Options box
  • Check that the new shortcut appears at Next source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.