0

We have bought the HP z4 g4 workstation with windows and I have uninstalled windows and installed ubuntu 18.04. While installing, I have got so many errors and I have corrected using online sources. But now, I am trying to install the nvidia-driver and installed the latest nvidia-driver (430) but when I check it with nvidia-smi, I am getting the following error.

I have installed nvidia-driver using the following command

sudo apt-get install nvidia-430

NVIDIA_SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest sriver is installed and running

lspci -k | grep -EA3 'VGA|3D|Display'

The above command produces the following output

00:1f.5 Non-VGA unclassified device: Intel Corporation 200 Series/Z370 Chipset F                                                                                        amily SPI Controller
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-LM
        Subsystem: Hewlett-Packard Company Ethernet Connection (2) I219-LM
        Kernel driver in use: e1000e
--
21:00.0 VGA compatible controller: NVIDIA Corporation Device 1e30 (rev a1)
        Subsystem: Hewlett-Packard Company Device 129e
        Kernel modules: nvidiafb, nouveau
21:00.1 Audio device: NVIDIA Corporation Device 10f7 (rev a1)

I have tried many possibilities but I couldn't correct and your help towards this is highly appreciated.

I have the following properites in secure boothttps://drive.google.com/file/d/1QnTDLKnjPVWnKzyOIF2hgafmvPkgoCKV/view?usp=sharing

11
  • 1
    How did you install the driver? Please edit your question and add output of lspci -k | grep -EA3 'VGA|3D|Display' terminal command. – Pilot6 Oct 15 '19 at 14:43
  • Please EDIT YOUR QUESTION and add output there. It is unreadable in comments. – Pilot6 Oct 15 '19 at 15:00
  • I have updated the comment. please check it. – vinayakumar R Oct 15 '19 at 15:04
  • There is no nvidia-430 package for ubuntu 18.04. Did your install command install anything? Also check if Secure Boot is disabled in BIOS. – Pilot6 Oct 15 '19 at 15:06
  • Yes, it installed some libraries. Even I have tried with .run package. This also didn't work. I have uninsalled all the nvidia drivers. Now nvidia-smi prodduces the following output: Command 'nvidia-smi' not found, but can be installed with: sudo apt install nvidia-340 sudo apt install nvidia-utils-390 – vinayakumar R Oct 15 '19 at 15:08
0

To install the driver properly disable Secure Boot in BIOS if you are using UEFI and install by

sudo apt install nvidia-driver-430

In your case the correct BIOS option is

Legacy Support Disable and Secure Boot Disable
1
  • I have installed using the same command and the secure boot option which I have is given in the attached image (in the above question) – vinayakumar R Oct 15 '19 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.