0

Ruunog Ubuntu 18.04 wiht Netplan and bionic-baaver so it seems. When I configured the OS I have to configure it using DHCP SO once up, I wish to change networking so I configure the .YAML file under /etc/netplan but the setting does not get applied ever. Googled and tried many options to no effect.

# network: {config: disabled}
network:
    ethernets:
        ens32:
            dhcp4: true
            match:
                    macaddress: 00:0c:29:68:6a:b0
            mtu: 1450
    version: 2


ens32: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1450 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:0c:29:68:6a:b0 brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.176/24 brd 192.168.2.255 scope global dynamic ens32
       valid_lft 83498sec preferred_lft 83498sec
    inet6 fe80::20c:29ff:fe68:6ab0/64 scope link
       valid_lft forever preferred_lft forever

I use the netplan try - seems to validate but when I apply netplan apply it still has a static address. BUt even if I change the .YAML file to a static and different IP I seem to be even unable to change it to anything else .Very confusing. Config below seems to get rejected and the interface ens32 seems to be down.

network:
    ethernets:
        ens32:
          addresses:
              - 192.168.2.56
          gateway4: 192.168.2.1
          mtu : 1450
          nameservers:
              addresses:
                 - 192.168.2.33
                 - 192.168.2.20
                version: 2

Help, would appreciate any advice/help. Thanks

  • Is this a server, or a desktop installation? If server, did you run the config disable program? .yaml files are very fussy about spacing, indentation, and tabs (not permitted). Change your indentation to two spaces. Remove tabs. Some .yaml files require a reboot to stick... like for static address changes, etc. Edit your question and show us sudo netplan --debug generate and sudo netplan apply. – heynnema Oct 14 at 20:41
  • Hi,Thanks for the feedback. NOt sure what the config disable program is or what I need to do. yes it is server edition. I will remove any TABS and makes changes and provide the output form the debug. Thanks again – missingit Oct 15 at 8:32
  • So when I run the debug after removing all the TABS and indenting each by 2 spaces – missingit Oct 15 at 9:19
  • Processing input file //etc/netplan/10-systemd-networkd-eth.yaml.. ** (generate:1571): DEBUG: 00:08:01.444: starting new processing pass ** (generate:1571): DEBUG: 00:08:01.444: ens32: setting default backend to 1 ** (generate:1571): DEBUG: 00:08:01.444: Generating output files.. ** (generate:1571): DEBUG: 00:08:01.444: NetworkManager: definition eno1 is not for us (backend 1) – missingit Oct 15 at 9:32
  • Edit data into your question, not in the comments, please. Show me your current .yaml, and sudo lshw -C network and cat /etc/network/interfaces. What happened after the sudo netplan apply? The cloud disable question comes from seeing "{config: disabled}". The script to disable netplan is in (from memory) /etc/cloud/cloud-init.d. Did you run that during install, or later? Why MTU 1450... are you on DSL? – heynnema Oct 15 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.