5

I've tried just about everything there is to try and I still can't seem to get my Wi-Fi card working.

I've got a Dell Vostro 14 5490 laptop.

It appears that I don't have a working driver for my card or something along those lines. The Wi-Fi menu in the setting GUI says "No Wi-Fi Adapter Found".

Though, I know there is one and it functions perfectly because I have Windows installed in dual-boot and it works fine on it. I have verified there is no switch on the laptop and the setting is on in the BIOS.

Also, I found this link to some drivers for intel wireless cards for linux. I wasn't sure which, if any of these would work for my card. I've just installed the iwlwifi-9000-pu-b0-jf-b0-34.618819.0.tgz and the iwlwifi-9260-th-b0-jf-b0-34.618819.0.tgz drivers. (I'm also not certain if my process in installing these was correct either; all I did was downloaded them and move them to /lib/firmware/ and then unzipped them there. Leaving the zip files and everything in the directory) I did not have any luck in doing this - I even tried restarting the computer.

$ lspci -nn | grep -i network
Network Controller [0280]: Intel Corporation Device [8086:02f0]
$ uname -r
5.0.0-31-generic
$ iwconfig
enp2s0    no wireless extensions.
lo    no wireless extionsions
$ sudo lshw -C network
*-network
    description: Network controller
    product: Intel Corporation
    vendor: Intel Corporation
    physical id: 14.3
    version: 00
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress msix bus_master cap_list
    configuration: driver=iwlwifi latency=0
    resources: irq:16 memory:cc22a0000-c22a3fff
$ dmesg | grep -i firm
[    0.204901] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    1.233739] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
[    1.364414] [Firmware Bug]: ACPI(PXSX) defines _DOD but not _DOS
[   20.643192] iwlwifi 0000:00:14.3: loaded firmware version 43.95eb4e97.0 op_mode iwlmvm
[   21.051100] Bluetooth: hci0: Firmware revision 0.0 build 26 week 21 2019
[   26.210254] iwlwifi 0000:00:14.3: Failed to load firmware chunk!
$ sudo dpkg -s linux-firmware | grep Ver
Version: 1.178.3

After running the linux-firmware update as per the answer below by chili555, I ran the following and got the following output:

$ dmesg | grep iwl

Since the output was so huge, I put it into this pastebin: https://pastebin.com/M9eFfqxd

Also, during the linux-firmware update, I got a couple informational prints that said:

I: The initramfs will attempt to resume from /dev/dm-2
I: (/dev/mapper/ubuntu--vg-swap_1)
I: Set the RESUME variable to override this.

After running the second set of commands in the answer below by chili555, I received the following output:

$ dmesg | grep iwl

Again, due to the output being so massive, I've included it in this pastebin: https://pastebin.com/QH8zPmgL

The wifi functionality now appears to be working properly subsequent to running the commands in chili555's answer.

  • Do you have some kind of wifi switch or button you can toggle? – mchid Oct 14 '19 at 4:09
  • @mchid This particular laptop does not have a switch, I've also checked to make sure it's enabled in the BIOS. – xorist Oct 14 '19 at 4:11
  • Try holding down "Fn" and "2" to turn on wireless. – mchid Oct 14 '19 at 4:14
  • @mchid holding "Fn" and pressing "2" did not seem to yield any results unfortunately – xorist Oct 14 '19 at 4:17
  • does dmesg | grep -i firm output any messages about iwlwifi firmware? – ubfan1 Oct 14 '19 at 4:36
5

I believe that your device uses the Qu- and Quz-series of firmware blobs, not the 9000- or 9260-series; reference: https://bugs.launchpad.net/hwe-next/+bug/1833065 at comment #4. I believe that the later linux-firmware version 1.183 contains the referenced 48.xx versions. Please install it:

wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.183_all.deb
sudo dpkg -i linux*.deb

Reboot and show us:

dmesg | grep iwl

EDIT: The referenced bug report further suggests that the bug is fixed in the package linux-oem-osp1. Please install it:

sudo apt update
sudo apt install linux-oem-osp1

Several dependencies will also be installed.

Reboot and show us a new:

dmesg | grep iwl
  • I've ran the commands and updated my question with the output. The wifi still does not appear to work, but I did receive a couple of interesting outputs during the update process - which I also added to the question. – xorist Oct 14 '19 at 16:18
  • Please see my edit in a few minutes. – chili555 Oct 14 '19 at 16:21
  • WiFi appears to be working now, I've supplied the requested information in my answer. I didn't know if you'd like to check it for anything else that might be wrong at the moment. Thanks for your help. – xorist Oct 14 '19 at 17:23
  • One small issue seems to be that my signal strength is weak, but that could easily be due to the laptop it's self. Not sure if you have any suggestions for that, that would pertain to the question. – xorist Oct 14 '19 at 17:32
  • I confirmed the connection issue also exists on Windows, so I am going to chalk it up to the laptop's antennas. Thanks again for everything! – xorist Oct 14 '19 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.