1

I have W10/Ubuntu 18 dual boot, both systems on one SSD (booting BIOS, not UEFI) Recent W10 update messed up my partitions and I got grub rescue screen. I was able to fix it with recovering linux partition using parted rescue. After that I was able to boot, selected W10 and it successfully finished the update process. After that I was able to boot int Ubuntu, but with a slight issue - "No symbol table"

I run

sudo grub-install /dev/sda
sudo update-grub

It fixed the linux boot, but now when I select my W10 from grub menu it just reboots and back to the grub menu.

Here is my disk partitions:

~$ sudo parted /dev/sda print
Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type      File system     Flags
 1      1049kB  106MB  105MB   primary   ntfs
 2      106MB   144GB  144GB   primary   ntfs            boot
 3      144GB   144GB  543MB   primary   ntfs            diag
 4      144GB   256GB  112GB   extended
 6      144GB   248GB  104GB   logical   ext4
 5      248GB   256GB  8210MB  logical   linux-swap(v1)

My W10 is number 3, which I confirm by ls (hd0,msdos2)/ in grub

What I see in the grub.cfg for W10 section:

menuentry 'Windows 10 (on /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-68349BA7349B7732' {
        savedefault
        insmod part_msdos
        insmod ntfs
        set root='hd0,msdos1'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  68349BA7349B7732
        else
          search --no-floppy --fs-uuid --set=root 68349BA7349B7732
        fi
        parttool ${root} hidden-
        drivemap -s (hd0) ${root}
        chainloader +1
}

That seems to be wrong as it points to hd0,msdos1 the small reserved partition, the UUID of W10 partition is 86CA9C8FCA9C7CDD and it is hd0,msdos2 (/dev/sda2)

I tried to re-run os-prober and update-grub, but nothing changes. Please help me to recover my W10 booting from grub menu, thanks in advance.

  • Windows in BIOS boot mode normally has a small Boot partition that is the correct partition for grub to boot. But grub only boots working Windows. If Windows needs chkdsk or is hibernated (and that includes fast start up) then grub will not boot it. You then have to temporarily install a Windows boot loader, fix Windows & then restore grub. If still issues post link to Summary report from Boot-Repair. help.ubuntu.com/community/Boot-Repair – oldfred Oct 13 '19 at 2:38
  • Make a copy of grub.cfg. Then open it with sudo gedit /boot/grub/grub.cfg. Go to the Windows 10 menuentry and change all entries of msdos1 to msdos2. Also check that the correct UUID for sda2 is shown as well. Then save and reboot. – Paul Benson Oct 13 '19 at 5:16
  • Paul Benson - I actually tried that, but it resulted in BOOTMGR missing message, so I reverted the grub.cgf back to original – michael ubu Oct 13 '19 at 5:27
  • oldfred - here is the info page collected with boot-repair: paste.ubuntu.com/p/KgFN3Vs5F6 – michael ubu Oct 13 '19 at 5:28
  • That's nothing to do with grub or Ubuntu. If you try to boot into Windows independently from BIOS boot (you need to know the right 'F' key for your machine) it should show both systems. I expect that if you then try to boot Windows from there you will get the same message. It means your BCD file is corrupted or missing. – Paul Benson Oct 13 '19 at 6:28
0

Boot repair states:

=================== Suggested repair

The default repair of the Boot-Repair utility would reinstall the grub2 of
sda6 into the MBR of sda. 

Additional repair would be performed: unhide-bootmenu-10s fix-windows-boot

Select the Recommended Repair option to fix Windows boot:

boot repair

  • I followed through with boot-repair - recommended option, but it did not help. Now I have two W10 entries in the grub menu, one points to /dev/sda1 and second to /dev/sda2 and both result in just system rebooting right back into grub. So, that did not help. – michael ubu Oct 13 '19 at 17:39
  • My new info from boot-repair is here: paste.ubuntu.com/p/sMJSMsxGW3 – michael ubu Oct 13 '19 at 17:41
  • @michaelubu You can try boot-repair a second time. It's possible it finds new things to fix now. – WinEunuuchs2Unix Oct 13 '19 at 18:24
  • Retried, but nothing changed, still the same two W10 items on the grub menu, both result in reboot. – michael ubu Oct 13 '19 at 19:04
  • 1
    Boot-repair will not fix a Windows boot problem where there is a fault with a Windows boot file, which is what you have. You can repair this from Windows if you made a USB drive for a W10 installation, which has a repair feature as well. – Paul Benson Oct 13 '19 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.