I'm using Ubuntu 16.04 LTS and everything is upgraded and updated in my system .

But when i'm using internet with wired connection i will lose internet once in a while !

For using internet i must go setting/network and wired connection need to turn off and turn on again to work .

enter image description here

And this is my network driver information after running sudo lshw -C network:

   description: Ethernet interface
   product: 82579LM Gigabit Network Connection (Lewisville)
   vendor: Intel Corporation
   physical id: 19
   bus info: pci@0000:00:19.0
   logical name: eno1
   version: 04
   serial: 70:f3:95:01:c4:63
   size: 100Mbit/s
   capacity: 1Gbit/s
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion= duplex=full firmware=0.13-4 ip= latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
   resources: irq:28 memory:f7c00000-f7c1ffff memory:f7c39000-f7c39fff ioport:f080(size=32)

I checked my Lan cable . i tried updating my network driver and ... but i could't solve this problem .

how can i solve this problem ?

*UPDATE 1 : setting of wired connection : enter image description here

  • You probably have a cabling problem, as you're only getting 100Mb speed, or a switch/hub/router/modem that doesn't support 1Gb speed. Are you using cat 5e or cat 6 ethernet cabling? Please describe your ethernet cabling from the computer port to the modem.
    – heynnema
    Oct 12, 2019 at 20:17
  • @heynnema i have 2 safe lan cable and i changed the cable but problem not solved . i'm using cat5e cable . my modem is a LTE 4G modem
    – SAYE
    Oct 12, 2019 at 20:28
  • Check the specs on your 4G and see if it supports 1G speeds. It probably doesn't. That would explain the 100Mb speed that you're getting. The problem is probably an unreliable connection on/via the 4G modem. Does the modem show signal strength?
    – heynnema
    Oct 12, 2019 at 20:34
  • ps: some 4G modems have a setting which puts the modem to sleep, or disconnects after a set period of inactivity. Check your modem's settings panel.
    – heynnema
    Oct 12, 2019 at 20:39
  • @heynnema problem is not about modem because when my ubunutu is disconnected i can use internet by wifi on another device
    – SAYE
    Oct 13, 2019 at 7:37

2 Answers 2


From the comments...

Problem still exists when booting from a Ubuntu 16.04 Live USB. Try booting to a Ubuntu 19.04 Live USB and see if the problem is solved.

Check your BIOS version...

sudo dmidecode -s bios-version

It should be version 9SKT9CA.

If not, go to https://support.lenovo.com/us/en/downloads/ds029265 and download one of the updaters and apply.

Update #1:

User reports BIOS is 9SKT9CAUS

Update #2:

User reports that the problem is solved when booted to a Ubuntu Live 18.04 USB, but wishes to stay with 16.04.

Update #3:

User decided to upgrade to 18.04 anyway, and the problem is solved.

  • the version of bios is 9SKT9CAUS . Do I need to update?
    – SAYE
    Oct 16, 2019 at 18:31
  • @abasnikzad I suspect that 9SKT9CAUS is probably fine. Do try the Ubuntu Live 19.04 or 19.10 (available on 10/17/19) and see if the problem still exists.
    – heynnema
    Oct 17, 2019 at 2:41
  • I tested on Ubuntu 18.04 LTS latest version and problem solved but i prefer to use 16.04 .
    – SAYE
    Oct 17, 2019 at 17:21
  • @abasnikzad as you might expect... I'd encourage you to upgrade to 18.04 or newer.
    – heynnema
    Oct 17, 2019 at 18:28
  • 1
    @abasnikzad I would say yes.
    – heynnema
    Oct 17, 2019 at 21:32

With Mr. @heynnema 's guidance and answer we conclude that the problem is Ubuntu 16.04 .

I checked problem in Ubuntu 16.04 LTS [ubuntu live from USB] and the problem was still there .

Now i upgraded to Ubuntu 18.04 LTS and my problem is solved .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.