0

Afternoon all.

Yesterday (11th Oct) at midnight, my laptop lost connection to the internet via ethernet cable. I can still connect via wifi.

I have a second laptop, which dual boots with Xubuntu 19.04 and Windows 10. This second laptop can still connect to ethernet in both Windows 10 and Xubuntu 19.04, so it is not a modem / router issue.

I had managed to restore the ethernet by deleting the auto eth0 settings, and reconfiguring, but now that too has stopped working (and I cannot restore auto eth0!).

Can anyone help walk me through troubleshooting this issue please?


@heynnema: the information you requested.

dkms status
digimend, 8, 5.0.0-29-generic, x86_64: installed
digimend, 8, 5.0.0-31-generic, x86_64: installed
sudo lshw -C network
[sudo] password for bac: 
  *-network                 
       description: Ethernet interface
       product: RTL810xE PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: enp7s0
       version: 07
       serial: b0:5a:da:c9:aa:2a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical
       configuration: broadcast=yes driver=r8169 latency=0 multicast=yes
       resources: irq:18 ioport:4000(size=256) memory:b4000000-b4000fff memory:b4800000-b4803fff
  *-network
       description: Wireless interface
       product: Wireless 3165
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:0d:00.0
       logical name: wlp13s0
       version: 81
       serial: 94:65:9c:b9:9a:ba
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.0.0-31-generic firmware=29.1044073957.0 ip=192.168.1.114 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:44 memory:b2000000-b2001fff
cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
cat /etc/netplan/*.yaml
cat: '/etc/netplan/*.yaml': No such file or directory

@heynnema: The second run at sudo lshw -C network:

  *-network
       description: Ethernet interface
       product: RTL810xE PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: enp7s0
       version: 07
       serial: b0:5a:da:c9:aa:2a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical
       configuration: broadcast=yes driver=r8169 latency=0 multicast=yes
       resources: irq:18 ioport:4000(size=256) memory:b4000000-b4000fff memory:b4800000-b4803fff
  *-network
       description: Wireless interface
       product: Wireless 3165
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:0d:00.0
       logical name: wlp13s0
       version: 81
       serial: 94:65:9c:b9:9a:ba
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.0.0-31-generic firmware=29.1044073957.0 latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:44 memory:b2000000-b2001fff

@heynnema: Third times the charm!

sudo lshw -C network
  *-network
       description: Ethernet interface
       product: RTL810xE PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: enp7s0
       version: 07
       serial: b0:5a:da:c9:aa:2a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical
       configuration: broadcast=yes driver=r8169 latency=0 multicast=yes
       resources: irq:18 ioport:4000(size=256) memory:b4000000-b4000fff memory:b4800000-b4803fff
  *-network
       description: Wireless interface
       product: Wireless 3165
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:0d:00.0
       logical name: wlp13s0
       version: 81
       serial: 94:65:9c:b9:9a:ba
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.0.0-31-generic firmware=29.1044073957.0 latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:43 memory:b2000000-b2001fff

But still no auto eth0. How would I know if I have a cat5 or cat6 cable?

@heynnema: This should hopefully be the last one:

sudo lshw -C network
  *-network
       description: Ethernet interface
       product: RTL810xE PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: enp7s0
       version: 07
       serial: b0:5a:da:c9:aa:2a
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl8106e-1_0.0.1 06/29/12 ip=192.168.1.195 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:18 ioport:4000(size=256) memory:b4000000-b4000fff memory:b4800000-b4803fff
  *-network DISABLED
       description: Wireless interface
       product: Wireless 3165
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:0d:00.0
       logical name: wlp13s0
       version: 81
       serial: 94:65:9c:b9:9a:ba
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.0.0-31-generic firmware=29.1044073957.0 latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:43 memory:b2000000-b2001fff
0

From the comments...

After lengthy troubleshooting using the sudo lshw -C network command, it looked like no cable was connected to the computer, or the cable was defective (user was not using a cat 5e or cat 6 cable), or the switch/hub/router/modem wasn't connected.

It was determined that the computer really saw a enp7s0 ethernet device, not a eth0 device. By creating a new fresh NetworkManager GUI connection script using enp7s0, and testing with kernels -29, -30, and -31, it all seems to work again. Old connection scripts using eth0 were deleted.

If it fails again, you'll need to boot to a Ubuntu Live DVD/USB and retest the ethernet network interface.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.