4

I'm on Ubuntu 18.04. I'm trying to install EAGLE as instructed here. I've downloaded and unzipped the package and placed it in my home directory.

In the eagle folder, I run ./eagle run and got the following error:

$ ./eagle run
Warning: QT_DEVICE_PIXEL_RATIO is deprecated. Instead use:
   QT_AUTO_SCREEN_SCALE_FACTOR to enable platform plugin controlled per-screen factors.
   QT_SCREEN_SCALE_FACTORS to set per-screen factors.
   QT_SCALE_FACTOR to set the application global scale factor.
./eagle: symbol lookup error: /usr/lib/x86_64-linux-gnu/libGLX_mesa.so.0: undefined symbol: xcb_dri3_get_supported_modifiers

I tried running sudo ./eagle run and got this instead:

$ sudo ./eagle run
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
./eagle: symbol lookup error: /usr/lib/x86_64-linux-gnu/libGLX_mesa.so.0: undefined symbol: xcb_dri3_get_supported_modifiers

Using sudo wasn't mentioned in the instructions, but I tried it anyway. I'm not sure how I should deal with those 2 errors. How should I fix this to run EAGLE?

Update 1:

I tried running the following:

~$ dpkg -S /usr/lib/x86_64-linux-gnu/libGLX_mesa.so
dpkg-query: no path found matching pattern /usr/lib/x86_64-linux-gnu/libGLX_mesa.so
~$ apt-cache policy $(dpkg -S /usr/lib/x86_64-linux-gnu/libGLX_mesa.so.0 | awk -F ":" '{print $1}')
libglx-mesa0:
  Installed: 19.0.8-0ubuntu0~18.04.2
  Candidate: 19.0.8-0ubuntu0~18.04.3
  Version table:
     19.0.8-0ubuntu0~18.04.3 500
        500 http://vn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
 *** 19.0.8-0ubuntu0~18.04.2 100
        100 /var/lib/dpkg/status
     18.0.0~rc5-1ubuntu1 500
        500 http://vn.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
~$ dpkg -l | grep -i hwe
ii  linux-generic-hwe-18.04                    5.0.0.31.88                                     amd64        Complete Generic Linux kernel and headers
ii  linux-headers-generic-hwe-18.04            5.0.0.31.88                                     amd64        Generic Linux kernel headers
ii  linux-image-generic-hwe-18.04              5.0.0.31.88                                     amd64        Generic Linux kernel image
ii  linux-signed-generic-hwe-18.04             5.0.0.31.88                                     amd64        Complete Signed Generic Linux kernel and headers (dummy transitional package)
ii  xserver-xorg-core-hwe-18.04                2:1.20.4-1ubuntu3~18.04.1                       amd64        Xorg X server - core server
ii  xserver-xorg-hwe-18.04                     1:7.7+19ubuntu8~18.04.2                         amd64        X.Org X server
ii  xserver-xorg-input-all-hwe-18.04           1:7.7+19ubuntu8~18.04.2                         amd64        X.Org X server -- input driver metapackage
ii  xserver-xorg-input-libinput-hwe-18.04      0.28.1-1~18.04.1                                amd64        X.Org X server -- libinput input driver
ii  xserver-xorg-input-wacom-hwe-18.04         1:0.36.1-0ubuntu1~18.04.1                       amd64        X.Org X server -- Wacom input driver
ii  xserver-xorg-legacy-hwe-18.04              2:1.20.4-1ubuntu3~18.04.1                       amd64        setuid root Xorg server wrapper
ii  xserver-xorg-video-all-hwe-18.04           1:7.7+19ubuntu8~18.04.2                         amd64        X.Org X server -- output driver metapackage
ii  xserver-xorg-video-amdgpu-hwe-18.04        19.0.1-1~18.04.1                                amd64        X.Org X server -- AMDGPU display driver
ii  xserver-xorg-video-ati-hwe-18.04           1:19.0.1-0ubuntu1~18.04.1                       amd64        X.Org X server -- AMD/ATI display driver wrapper
ii  xserver-xorg-video-fbdev-hwe-18.04         1:0.5.0-1ubuntu1~18.04.1                        amd64        X.Org X server -- fbdev display driver
ii  xserver-xorg-video-intel-hwe-18.04         2:2.99.917+git20171229-1ubuntu1~18.04.1         amd64        X.Org X server -- Intel i8xx, i9xx display driver
ii  xserver-xorg-video-nouveau-hwe-18.04       1:1.0.16-1~18.04.1                              amd64        X.Org X server -- Nouveau display driver
ii  xserver-xorg-video-qxl-hwe-18.04           0.1.5-2build2~18.04.1                           amd64        X.Org X server -- QXL display driver
ii  xserver-xorg-video-radeon-hwe-18.04        1:19.0.1-0ubuntu1~18.04.1                       amd64        X.Org X server -- AMD/ATI Radeon display driver
ii  xserver-xorg-video-vesa-hwe-18.04          1:2.4.0-1~18.04.1                               amd64        X.Org X server -- VESA display driver
ii  xserver-xorg-video-vmware-hwe-18.04        1:13.3.0-2build1~18.04.1                        amd64        X.Org X server -- VMware display driver

Update 2:

I ran some more commands:

~$ ldd Eagle | grep local
ldd: ./Eagle: not regular file
~$ lsmod | grep drm
drm_kms_helper        180224  1 i915
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
fb_sys_fops            16384  1 drm_kms_helper
drm                   483328  16 drm_kms_helper,i915
~$ lspci | grep -iE "VGA|Video|Graphics"
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
4
  • Which video adapter and drivers do you use? Please install all upgrades with sudo apt-get update followed by sudo apt-get dist-upgrade to get newest dependencies on 18.04 LTS. And then retry to run EAGLE.
    – N0rbert
    Oct 12, 2019 at 12:51
  • I ran sudo apt update; sudo apt upgrade but it still returns the same errors. Also, EAGLE worked just fine when I used it on Windows (purely Ubuntu now) so I don't think the hardware is the cause. Oct 12, 2019 at 13:32
  • Please execute ldd eagle | grep local on its folder and add output to the question. Are you using Nvidia or ATI/AMD video card? Please add output of lsmod | grep drm and lspci | grep -iE "VGA|Video|Graphics" to the question. On my 18.04 LTS system EAGLE works on Intel and on VM.
    – N0rbert
    Oct 12, 2019 at 14:22
  • my Eagle folder is "Eagle" rather than "eagle" so I typed ldd Eagle | grep local instead Oct 13, 2019 at 6:01

1 Answer 1

6

Per the README

-- Linux Graphics Driver Issues Nouveau (Open Source driver for nVidia cards) may cause sporadic crashes during the login procedure.

Enable software rendering in libGL by setting LIBGL_ALWAYS_SOFTWARE to 1.

export LIBGL_ALWAYS_SOFTWARE=1 ./eagle

I ran

$: export LIBGL_ALWAYS_SOFTWARE=1

then ran the executable and it worked

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .