0

I just purchased a Slim USB 3.0 to HDMI® External Video Card from Starlink on amazon and I have gone through many of these before. I am trying to get it to connect to my monitor as my HDMI port has fried, but no matter how I install DisplayLink drivers, It always does not work. So I took to the internet and did some research. A lot of them just said to download the driver and then run it. Some of them mentioned running sudo apt update && sudo apt install dkms. I tried that but it did not work. then another website suggested running dmesg to see if the device is connected, but I don't know how to use it. the output is down below. But I don't know how to interpret this information. Your help is greatly appreciated. edit: https://pastebin.com/eh1c4wcF edit: just tried disabling ACPI temporarily, caused two things to happen; 1. my HDMI adapter still didn't work 2. my computer began detecting the hardware that it did not have such as a hardware-enabled airplane mode switch. I don't know what ACPI does, but it did not help. Ok, so I just deleted and reinstalled ubuntu and installed DisplayLink under this fresh installation, and it did not work. I have no idea what to do now.

0

From the Pastebin link that you mentioned I could find the error that

ACPI FADT declares the system doesn't support PCIe ASPM, so disable it

So you need to disable the ACPI

For disabling that you can refer to this link How do I disable ACPI when booting?

  • On a different note: for me, the nextcloud sync client appimage utterly shatters USB 3.0 displaylink functionality. It seems to make the system try and run the displaylink functionality inside the appimage. – rasmus91 Oct 11 at 21:04
  • sorry, dident work – asdfghjkl40362 Nice Oct 12 at 3:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.