3

I am not able to install Brave Browser and cannot seem to fix it.

W: GPG error: https://brave-browser-apt-release.s3.brave.com cosmic 
InRelease: The following signatures were invalid: EXPKEYSIG 4FE13824E3FFC656 Brave Software <support@brave.com>
E: The repository 'https://brave-browser-apt-release.s3.brave.com cosmic InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

I tried sudo apt-key list | grep expired and got:

pub   rsa4096 2018-10-15 [SC] [expired: 2019-04-13]
uid           [ expired] Brave Software <support@brave.com>

I did sudo apt-key adv --keyserver keys.gnupg.net --recv-keys 4FE13824E3FFC656 and got:

Executing: /tmp/apt-key-gpghome.1CQeA81kHh/gpg.1.sh --keyserver keys.gnupg.net --recv-keys 4FE13824E3FFC656
gpg: keyserver receive failed: No data

Now I am stuck. Can anyone help?

2
  • Are you using cosmic?
    – DK Bose
    Oct 11, 2019 at 16:51
  • @DKBose Yes, I am. 18.10
    – ticotexas
    Oct 11, 2019 at 17:08

3 Answers 3

1

If you are using ubuntu 16.04 or higher you can install brave using snap store. Open your terminal and type sudo snap install brave then enter.

1
  • Thanks, but I prefer to get the latest stable release which snap does not provide.
    – ticotexas
    Oct 11, 2019 at 17:04
1

Got it working with sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 4FE13824E3FFC656

0

you can add apt-key under brave-key server

  sudo apt-key adv --keyserver brave-browser-apt-release.s3.brave.com --recv-keys <your missing public key>

Not the answer you're looking for? Browse other questions tagged or ask your own question.