0

I have installed Kubuntu 19.04 in a laptop and a pc. In the laptop Im trying to share, via samba, a ntfs partition with just data (this is not the partition where Kubuntu was installed).

Then right-clicking the partition in dolphin, in properties, I set it to be shared. Then the shared partition appears in the workgroup (in the net smb shared folders on dolphin), however trying to access to the partition dolphin says "the file or folder smb://user/data doesn't exists", however this doesn't happen with a different shared folder (this folder is the public folder that comes with the kubuntu installation, and I shared it via right-click also).

Strangely no one of the shared folders appear in the smb.conf file, but the public folder is shared correctly.

Im newby on linux distributions so I dont know exactly what Im doing wrong. Can you help me?

1

Strangely no one of the shared folders appear in the smb.conf file, but the public folder is shared correctly.

Because you created the share from your file manager. Your samba shares will be listed in the output of this command:

net usershare info --long

In order for an smb client to access a Linux samba share 3 things are required:

[1] The samba client user must have permissions to access the samba share.

If you set the share to allow guest access then credentials are not required. If you created a private share but didn't create credentials you would get an error but not a "folder does not exist" error.

[2] The Linux permissions of the object that is shared must be consistent with how the samba share is set up.

It sounds like you did that part. If you didn't you would get an error but not a "folder does not exist" error.

[3] The path to the shared object must allow the smb client user to traverse parent folders to get to the shared object.

This is consistent with a "folder does not exist" error. What is the path to the shared folder? Is it /media/username/data?

If it is change the mount point to someplace else like /media/data ...

OR do something like this in smb.conf: Cannot access shared floder on ubuntu from windows 10 meanwhile I have access to default Public folder

  • thank you for your time, I will try to fix it with this information – Masacroso Oct 12 '19 at 21:28
  • my solution was just write force user =userin the smb.conf file, where ùser`is my user in kubuntu – Masacroso Oct 18 '19 at 10:32
0

You may check the folder from the permission tab. If you enabled public access on your shared folder, you might at least read and execute permission for Others otherwise the shared folder will not have permission to display content.

  • I have enabled all permissions on this folder, for me or others, but trying to access it from the workgroup (in any computer) it says that the folder doesnt exists – Masacroso Oct 11 '19 at 16:14
  • I already had some this kind of issue when sharing a folder directly in the root of personal folder. Can you try to unshare, create a subfolder, move your folder into now subfolder and share your folder again? – ob2 Oct 11 '19 at 21:33
  • I will try this, thanks – Masacroso Oct 11 '19 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.