2

I'm encountering a connection issue to my university WiFi network that I cannot solve: when attempting to connect, I get the following message with dmesg -T :

[ven. oct. 11 12:32:04 2019] wlan0: deauthenticating from X by local choice (Reason: 3=DEAUTH_LEAVING)

This problem has already been pointed out in the forum, but none of the solutions I tried worked:

  • Disabling the powersave for WiFi (in /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf set wifi.powersave = 2 ).
  • Changing from NetworkManager to WICD.
  • Adding the following lines to /etc/sysctl.conf:

    net.ipv6.conf.all.disable_ipv6 = 1
    net.ipv6.conf.default.disable_ipv6 = 1
    net.ipv6.conf.lo.disable_ipv6 = 1
    

None of these worked.

1 Answer 1

-1

I just met this problem this morning and fixed it.

Here is my suggestion.

Set your WiFi to no password mode to simplify the operation to connect.

Turn off net services:

systemctl list-units | grep -iE '(net|dhcp|wpa|conn|wicd)'

and you can see some services is running

systemctl stop [your running services]

Open your wlan0:

ifconfig wlan0 up

Connect wifi:

iwconfig wlan0 essid [your wifi name]

DHCP IP:

dhclient wlan0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.