2

I have a Fujitsu Lifebook E780 with Ubuntu 18.04.3 LTS.

When i boot my PC in quiet splash mode after the purple screen I get a black screen for some second and then this splash screen,

Splash screen

But after less then a second the splash screen disappear leaving back just a black screen for the rest of the boot.

The boot is very slow (1 min 40s on average) and gives the following errors:

19:41:36 colord-sane: io/hpmud/pp.c 627: unable to read device-id ret=-1
19:41:25 bluetoothd: Failed to set mode: Blocked through rfkill (0x12)
19:41:25 spice-vdagent: Cannot access vdagent virtio channel /dev/virtio-ports/com.redhat.spice.0
19:41:20 pulseaudio: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided by any .service files
19:41:11 wpa_supplicant: dbus: Failed to construct signal
19:40:56 bluetoothd: Failed to set mode: Blocked through rfkill (0x12)
19:40:46 kernel: Bluetooth: hci0: unexpected event for opcode 0x0000
19:40:46 kernel: mei mei::55213584-9a29-4916-badf-0fb7ed682aeb:01: FW version command failed -5
19:40:21 kernel: ima: Error Communicating to TPM chip
19:40:21 kernel: ACPI: SPCR: Unexpected SPCR Access Width.  Defaulting to byte size

None of these errors seems to be somehow related to the splash screen problem but I'm not sure of this.

Here there is the /etc/default/grub content that shows my boot settings

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

EDIT:

I have tried to use nomodeset and the splash screen warks fine(obviously with low resolution), so probably is same graphical driver issue

EDIT2: I have just noticed that pressing esc make the splash screen show up, but this doesn't mean thet the problem is solved

  • 1
    If it will help the technical term is "Plymouth" that controls the splash screen. – WinEunuuchs2Unix Oct 11 '19 at 17:37
  • 1
    @WinEunuuchs2Unix Thanks you, this helped a lot on my researches end bring me to find a solution for the problem – Emanuele Scarsella Oct 12 '19 at 12:53
  • I hoped once you knew what to google for you would find the solution. Please post an answer with your solution to benefit others. – WinEunuuchs2Unix Oct 12 '19 at 15:15
  • @WinEunuuchs2Unix Yes, It helped a lot in fact I found the solution tonight (here in Italy... Is late). Tomorrow in the morning I will certainly publish the solution. I know how important is to leave as much help as possible to the ones who will see this page in future ☺️ – Emanuele Scarsella Oct 12 '19 at 19:27
1

The way I see it the output you shared are the reasons for the delay in boot.

  • You can switch off / uninstall (Bluetooth for example) or install the correct drivers.
  • Try looking up for each error on Google.

You can also disable the respective services like Bluetoothd.

There is a lot of information regarding that on Google.

But I too get a black screen after the splash. So the only difference is the delay.

I suspect the maximum delay is with regards to the Wi-Fi chip. Find out the make and model of your Wi-Fi.

If that does not solve it, you could temporarily disable wireless on boot. Moreover, since many of the errors are related to Kernel bugs, I would recommend you switch to a different flavor of Linux or Ubuntu ..and repeat the steps wrt Grub and see if you get the same errors.

You can try with a Live Cd first.

If you have a Preference wrt Linux then you are here to solve it.. Is spice-vdagent required for Wayland? 2. How do I disable ACPI when booting? 3. How can I deactivate Bluetooth on system startup?

| improve this answer | |
  • Thanks for your answer but sadly it was not very useful to me: I have already searched those errors and none of the solution I have found works to solve the problem. Disinstallig/disabling Bluetooth and spice-vdagent don't speed up the boot and disabling the ACPI gives problem with the shoutdown. About changing flavor I prefer stay with this version especially now that I have found the solution to the splash screen an tomorrow I will post it. Anyway thanks for your advices, I can't mark this as an answer because is not about the main question, but I will vote up this because is a good answer – Emanuele Scarsella Oct 12 '19 at 18:10
1

Introduction to the problem

The part responsible for the splash screen is called Plymouth. As reported by Wiki.ArchLinux:

Plymouth is a project from Fedora and now listed among the freedesktop.org's official resources providing a flicker-free graphical boot process. It relies on kernel mode setting (KMS) to set the native resolution of the display as early as possible, then provides an eye-candy splash screen leading all the way up to the login manager.

According to this if there is some problem with the splash screen Plymouth is the responsible.


Solutions

To solve the problem I came out with a bit drastical solution that worked for me, but before solve the problem in my way I suggest you to use the following safer solution even if I'm not sure it will be enough becouse i have not tested it.

  • The more quiet solution

The only sure fact is that there is something wrong with the Plymonth, so the firt thing to try is to update the pakage because it could solve the problem end even if don't work surely will be painless.

To do this just use this command into the terminal:

sudo apt-get install plymouth

I was so sure it wouldn't have been enough that I haven't even tried to do this but is better give it a try.

  • The dangerous solution

If updating Plymouth was not enough to solve the problem, you have to uninstall it and reinstall it.

NOTICE: Plymouth is an important part of ubuntu and I'm not expert enough to say how safe is to uninstall it.

To uninstall the package use this command:

sudo apt-get purge plymouth

Pay attention to the output of this command because in my case it gives:

...
The following packages will be REMOVED:
plymouth* plymouth-label* plymouth-theme-ubuntu-logo*
plymouth-theme-ubuntu-text* plymouth-x11*
0 aggiornati, 0 installati, 5 da rimuovere e 0 non aggiornati.
Dopo quest'operazione, verranno liberati 696 kB di spazio su disco.
Continuare? [S/n]

But i have read that in some cases it also tries to remove packages like ubuntu-desktop*.
If it is your case is safer for you to not go forward and answer no.

otherwise, the next step to do is to reinstall it:

sudo apt-get install plymouth

Then reboot your system and the splash screen will appear but with this theme:

enter image description here

To change the theme, use the following command to display the list of available themes

aptitude search plymouth-theme

Then use this command to install the one you want (the default is plymouth-theme-ubuntu-logo)

sudo aptitude install #PUT THE THEME NAME HERE#

For example, to install the default theme the syntax is:

sudo aptitude install plymouth-theme-ubuntu-logo

This solved my problem and now the splash screen appear after just 6 seconds from the BIOS screen and don't disappear until the end of the boot

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.