0

I have a Dell's laptop (Model: DELL XPS 13 7390 2-in-1 laptop, Tag:F4V82Z2, with Intel's 10-gen CPU i7-1065G7, IceLake) that originally shipped with Windows 10 and I would like to dual boot it with Ubuntu 18.04.3. However, the boot always hangs and the laptop starts to be really hot.

What I tried:

I downloaded Ubuntu 18.04.3 (and also Ubuntu 19.04) from https://ubuntu.com/download/desktop Using Rufus-3.8 I made a USB boot drive (File system:Large FAT, Partition scheme: MBR).

HW:

  • I read online that USB-2 are not supported by Dell so I tried both USB-2 and USB-3 drives.
  • I ran the BIOS hardware check scan - Passed.

From within windows:

  • Just to make sure, I updated Windows to have the latest updates.
  • I downloaded Dell's update utility and ensure that I have the latest updates.
  • I updated the BIOS with the latest firmware since Oct 3, 2019
  • I ensured that Microsoft Bit Locker is suspended (although the disk is fully encrypted).
  • I shrank the C drive to un-allocate 200Gb for the Ubuntu boot.
  • I ensured that windows fast startup is disabled

From BIOS:

  • I tried to use secure boot enabled/disabled modes.
  • I tried switching the SATA configurations from RAID to ACHI
  • I ensured that only UEFI boot is enabled

After booting from the USB, the UBUNTU grab is opened and I choose "try ubuntu". Then, I am getting an error related to the ACPI tables. I edited the grab with the following configurations but the boot always hangs:

  • nosplash debug i915.nomodeset=0 max_cstate=1 acpi=off i915.nomodeset=0 max_cstate=1 acpi=off

  • nomodeset=0 max_cstate=1 acpi=off

  • nomodeset=0 

  • max_cstate=1 acpi=off

  • nomodeset=0 acpi=off

What can I do next?

Thanks.

2

In grub press e, then add modprobe.blacklist=intel_lpss_pci in the Linux line after "---" and press f10. That will get you to the full os.. then upgrading to kernel 5.3 will fix the wifi. I read that there are other ways to fix the wifi, by copying the Intel drivers in /lib/firmware, but that did not work for me..

I haven't found a way to get the touchscreen to work yet.. I read something about it sitting behind the intel_lpss module and someone made a driver patch, whatever that is, to get it to work.. but I haven't tried to apply it, nor I know how to.. seems to be a c program

1

Use 19.10 and it will work. I have the same computer. Also, touchscreen works almost perfectly in this version.

protected by Community Oct 26 at 20:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.