0

I am using a dual boot Laptop (Ubuntu 18.04 + Windows 10). I have the following partitions (please view the attached picture). The files that I copy from Ubuntu to my "General" and "Software" drives are not visible on Windows. These files are not hidden and have 777 permissions but I cannot find them anywhere on Windows. Is there any way I can access those files in both Ubuntu and Windows?

Thanks!

My partitions:

enter image description here

0

You may be experiencing the hibernation issue with Windows 10. If I remember correctly, Windows 10 by default uses a setting called "fast start" which puts the system into a special hibernation state instead of a full shut down to improve boot times (more info here). When restarting from this state, the OS does a kind of check/repair on the filesystem I believe. This could be what is deleting your files. You can disable "fast start" in the system power options:

Windows Power Options

If turning off "fast start" doesn't fix your problem, then after you copy the files in Ubuntu, unmount the NTFS partitions:

$ sudo umount /mnt/General # or wherever "General" partition is mounted

Then remount them to see if the files are still there. If they are, reboot into Windows. If you can now access the files from Windows, there could be an issue with files being cached for write to the filesystem but never actually get written. I'm not sure how that would be fixed, but usually (as I understand it) if files are cached, they will be written when the filesystem is unmounted. That could mean that the partitions are not being unmounted properly when the system is shut down.

If all else fails, there are some tools for Windows that can give you access to the ext2/3/4 partitions:

You should be able to use one of those to copy files from the Ext4 partition the NTFS ones in Windows.

| improve this answer | |
0

No need to panic. Just restart your windows OS and it works just fine.. Not even need to disable fast startup in Power options. This is done because when windows boot in fast startup mode it doesn't scan all drives and files in it that's why your files are hidden.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.