0

I can't seem to be able to use the TigerVNC viewer or Remmina with OpenVPN when the use only for resources on this network flag is checked in NetworkManager.

If I uncheck that flag it works as expected, by I end up passing all my internet traffic through a server that is 12.000km away. On the other hand, for other things like ssh connections, I can check the flag and I get internet for everything except when sshing into the domain of the VPN server.

If I understand correctly, the flag in NetworkManager sets custom routes for my domain.com (as an example) traffic. Then why doesn't VNC go that way by default?

Is there any way to make VNC behave like ssh while using VPN? (If the VNC server is in the same domain as the VPN server, use the VPN connection).

Cheers,

  • Where is that option? Can't seem to find it in "Edit Connections..." – Organic Marble Oct 9 '19 at 16:40
  • It's in the VPN settings, in the IPv4 and IPv6 tabs. – Sabian Oct 9 '19 at 16:44
  • Ah, I see, and click the Routes button. Thanks. – Organic Marble Oct 9 '19 at 16:45
0

You can use PuTTY and make a tunnel connection to the host.

1.As this picture, choose the host's IP address.
2.As this picture, choose the source port and destination. The destination is the thing that you have tried to connect by VPC viewer. The source port can be anything you want.

After that, on the VNC viewer, you should try to connect 127.0.0.1:9000.

  • Hi! Thanks for your answer. I was wondering, isn't this the same as creating an ssh tunnel? That I know it's a possible solution. However I was wondering if there is some solution using VPN. I'll expand my question accordingly. – Sabian Oct 9 '19 at 20:30
  • Yes, Exactly, it creates an ssh tunnel. I don't think so, VNC and ssh aren't related. – M. Rostami Oct 10 '19 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.