0

Not sure if these are related but are the issues I'm contending with. I have searched and tried various answers, but I am not getting anywhere.

Apologies my first post had many parts, I was simply trying to list the symptoms. I have edited out much of it.

ping 8.8.8.8 results 0% packet loss, but ping googleDOTcom results in Name or service not known.

EDIT nslookup results in no response, must EXIT to return to $ prompt. nslookup host returns: ;; connection timed out; no servers could be reached

EDIT dpkg --configure -a returns: nothing, back to $ prompt.

  • 1
    House rules ask folks to limit the scope of a question; asking for many things in a question is daunting, and often that's the kind of question folks don't invest their (volunteer) time in answering. See askubuntu.com/help/dont-ask What types of questions should I avoid asking? ...Your questions should be reasonably scoped. If you can imagine an entire book that answers your question, you’re asking too much. How about breaking this down into multiple questions by clicking on edit, removing all but questions, and then making the remainder into questions of their own? – K7AAY Oct 9 at 16:11
  • #2 and #5 could have the same cause; what's your DNS server? Please run nslookup (see ubuntu man nslookup) and add the result to questions 2 and 5 by clicking on edit. Please do not use Add Comment, but instead use edit. – K7AAY Oct 9 at 16:15
  • Re: #1: Please run dpkg --configure -a and advise the results by adding them to your question with edit. – K7AAY Oct 9 at 16:19
0

At first, you must add a static IP address to the indeed interface. if your network range is 192.168.1.0/24, try to do it:
ifconfig eth0 192.168.1.100 netmask 255.255.255.0 up.

After that, try to ping this IP to check out the interface status:
ping 192.168.1.1
ping 4.2.2.4

If everything goes well, remote add nameserver that is in /etc/resolv.conf and add nameserver 4.2.2.4 to this config file:
sudo nano /etc/resolv.conf

  • /etc/resolv.conf verbiage suggests to not edit the file, that it will be overwritten. I did try the ifconfig ~up command, returned to $ prompt. Ping computer IP and 4.2.2.4 both has 0% packet loss. In resolv.conf file, there is a recommendation to try systemd-resolve --status which returns: Failed to get global data: Unit dbus-org.freedesktop.resolve1.service not found. – Andy Daupert Oct 10 at 20:02
  • Alright, try to ping the gateway ping 192.168.1.1. Gateway is your modem or the device which connects you to the internet. – M. Rostami Oct 11 at 19:01
  • Pinged the router, 0% packet loss – Andy Daupert yesterday
  • Ok. So, Ubuntu access to the router. At first, are you sure that there is no mac filter configuration on the router? Or, are you sure the firewall of the Ubuntu is disabled? Maybe plenty of internal ports of the Ubuntu are disabled. You can check it out by another host on the Lan by nmap or some tools like that nmap -sV 192.168.1.100 or do it on the Ubuntu nmap -sV localhost. All in all, I think that there is some problem with the router. – M. Rostami yesterday

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.