0

Need help badly. I opened up Ubuntu, it needed an update run and I did that but I received an error message for 1 broken package. Opened up synaptic package manager to see that it was a package called linux-image-generic 4.15.0.65.67_amd64. So its new its the latest on Ubuntu's site. The error message is attached. I've tried complete removal through package manager and reinstall twice now. No go. Not sure what to do. Never had this problem before.

Thank you!

Error message detail after attempt at reinstallation

Update: tried running sudo apt-get install -f Result:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libllvm7 linux-headers-5.0.0-27 linux-headers-5.0.0-27-generic
  linux-image-5.0.0-27-generic linux-modules-5.0.0-27-generic
  linux-modules-extra-5.0.0-27-generic
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  linux-modules-extra-4.15.0-65-generic
The following NEW packages will be installed:
  linux-modules-extra-4.15.0-65-generic
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/32.9 MB of archives.
After this operation, 170 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
E: Invalid archive member header mu~|�0��ŵ a�d��Kj]�m��4���i�m�a\�8�a���<-�׫%g�Y}�0k�
E: Prior errors apply to /var/cache/apt/archives/linux-modules-extra-4.15.0-65-generic_4.15.0-65.74_amd64.deb
debconf: apt-extracttemplates failed: No such file or directory
(Reading database ... 402329 files and directories currently installed.)
Preparing to unpack .../linux-modules-extra-4.15.0-65-generic_4.15.0-65.74_amd64.deb ...
Unpacking linux-headers-4.15.0-65 (4.15.0-65.74) over (4.15.0-65.74) ...
Setting up linux-headers-4.15.0-65 (4.15.0-65.74) ...
dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-modules-extra-4.15.0-65-generic; however:
  Package linux-modules-extra-4.15.0-65-generic is not installed.

dpkg: error processing package linux-image-generic (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 linux-image-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

ALSO: In the properties of the package in manager this is what I have:

Depends: linux-image-4.15.0-65-generic
Conflicts:linux-image-generic
1

So what happened was that there was conflicting packages. Nothing to do with Firefox and not a duplicate of other posts thank you though :) I went into synaptic and completely removed the broken package and manually downloaded the latest version of the package that was specificed by the Ubuntu website that was trying to download. The auto commands did not take care of the issue. Had to be manual.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.